Bricked my drive with BIOS Hard Drive Password SSD

Kilobyte Kid

Bricked my drive with BIOS Hard Drive Password SSD

I **bleep** away several hours of my life recently, and because I could find nothing online about it, I figured I would post it here to save someone else the time.



Dell Precision M6400 Laptop

BIOS version A09/ SMBIOS Version 2.4

Intel ICH9M-E SATA RAID Controller


I put a couple of 256GB Crucial Solid State drives in the laptop and configured them for  RAID 0

I cloned my old hard disk partitions over using Acronis, and it worked like a charm... Used it for a day, and noticed that whenever I rebooted my system, or put the system into hibernation mode, I would lose one of the two drives on reboot (when the Intel Storage Matrix Controller BIOS message came up, it would show only one drive).  I was a bit freaked because the restore took over 7 hours, and I was not looking forward to doing it again... However, I noticed that if I shut off my laptop, pulled the battery and AC, replaced them and rebooted, it would show the second drive again... very strange...


Then, after I was comfortable with the restore and system functionality, I went into the BIOS and attempted to set hard drive passwords for the first and second installed drives.  The password went fine for the first drive, but when I tried to put it in on the other drive, it said I had incorrectly "entered the old password".  The dialog to set the second drive password showed only the two entry boxes... so I immediately knew something was nuts... (normally when there is an existing password, you have 3 boxes, old / new/ and new repeated.  I backed out of the BIOS and rebooted after powering down the laptop.


Now the fun part...  On the next boot, it prompted me like normal for the BioMetric finger swipe, but did not present the hard drive password STOP screen asking me to enter the password for the drive... instead, it went to the Intel Matrix Storage Driver BIOS screen and started it's attempt to scan my drives... at which time the boot process halted with this message...


"One or more of your hard drives is protected with a boot password.  Please restart your computer and remove the password"... or something along those lines.   The controller, naturally, could not access the drive because of the password, and the BIOS didn't prompt me for it... needless to say, I was completely screwed.  You cannot get into the BIOS in any way shape or form until after the controller BIOS loads... not via F2 or ANY other combination (no diagnostic boot didn't work either)... and the controller halts the system boot because it can't scan the drive.  Sure you can remove the drive, but you still have a bricked drive...


I then attempted to put the one drive that had the password in a Dell M90, an HP desktop and any other machine whose BIOS I knew support hard disk passwords... all of them saw there was a password installed on the drive, but non of them could match the password entry with the password stored on the drive... and no, I didn't forget the password-  :-)


Long and the short of it, I had to call Crucial support and they confirmed it was likely a conflict with the Dell BIOS that attempted to set the password, or some kind of a controller problem.... they suggested that a firmware update might help, but that they wouldn't risk trying to set a password again... I agree.


Because delivery would be exponentially faster, I RMA'd the drive to our supplier, and had them send me a new one.

I would love to tell you what firmware version the drives I had were at the time, but I can't even figure that out with these new ones I am about to put in and restart the clone...  I downloaded the latest firmware and am planning to burn it on the drives before I clone my old drive over to them... I guess I won't find out what version they are on until I run the update utility... could find the firmware information anywere