Crucial CT525MX300 won't boot or mount

Highlighted
Kilobyte Kid

Crucial CT525MX300 won't boot or mount

I had Crucial CT525MX300 as my startup disk on my mac mini, and was using my old sata disk as a second hd. However after a reboot yesterday the SSD wont boot up and went into recovery mode. I tried First Aid from Disk Utility but it was failing with Exit Code 8. Then I installed OS via internet on the old sata disk and boot up mac mini from it. But still cant make my SSD mount or repair with First Aid and it shows 0 available space. I have important data on it, please advise how can I fix it. Please see snapshots below:

 

Screen Shot 2017-02-16 at 10.11.34.png

Screen Shot 2017-02-16 at 10.23.17.png

Screen Shot 2017-02-16 at 10.24.26.png

 

5 Replies
Kilobyte Kid

Re: Crucial CT525MX300 won't boot or mount

The effected SSD is now not even showing up in diskutil list after couple of restarts Smiley Sad i.e. there is no sign of it!!

 

What a waste of money!!

 

 

JEDEC Jedi

Re: Crucial CT525MX300 won't boot or mount


jasanand wrote:

 

What a waste of money!!

 


The MX300 is too new to be out of warranty so you can get it replaced by RMAing it.

 

I'm sorry to say this won't help with your data. Smiley Sad  I know it doesn't help to say this now, and hindsight is a wonderful thing, but you must always backup anything you can't afford to lose.  No storage device from any manufacturer, no matter what it costs, is infallible.  All that happens is people swear off brand A because they had it fail and switch to brand B that other people have sworn off because that brand failed on them.  The only sure fire way to keep data safe is to back it up.

 

I know what it's like unfortunately.  Many years ago I had a RAID controller fail and take out all my data.  It wasn't backed up and I sure should have known better.  I think people only learn this lesson after it's too late. Smiley Sad

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
JEDEC Jedi

Re: Crucial CT525MX300 won't boot or mount

This is mainly for older drives without powerloss protection so I don't want to give you false hope but you probably may as well give this a go since you've little to lose at this point: http://forum.crucial.com/t5/Crucial-SSDs/Why-did-my-SSD-quot-disappear-quot-from-my-system/ta-p/6521...

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: Crucial CT525MX300 won't boot or mount

Agreed, backup is very important, and since I did not have one, hence the grunting...

Kilobyte Kid

Re: Crucial CT525MX300 won't boot or mount

Ok, I tried the following:

 

1. Booted mac mini with a ubuntu live usb, this showed me the ssd disk mount and I was able to cop my /Users/xxx dir, so manage to recover my home drive

2. Used hdparm to secure erase the SSD by following the steps on 

https://wiki.archlinux.org/index.php/Solid_State_Drives/Memory_cell_clearing

But I had to suspend and then wake up the system in order to get the ssd to unfrozen state. This got my ssd to an uninitialize state.

3. Rebooted into Recovery Mode and tried to erase the SSD but got error saying 'Error: -69760: Unable to write to the last block of the device'

4. Downloaded firmware update for M0CR040 to update my MX300 SSD which is currently on M0CR031

5. Followed the steps on https://blog.grimneko.de/2015/10/06/ssd-firmware-upgrade-os-x/ to create a usb to update the SSD firmware

6. Booted mac from the usb in step 5 to update SSD firmware, the firmware update started but failed with status 13

7. Tried again to erase but still getting error saying 'Error: -69760: Unable to write to the last block of the device'

 

Giving up now Smiley Sad

 

Guess will have to do the daunting task of opening up mac mini to get the SSD out and send it back !!