Crucial MX300 SDD - Windows 10 Freezing (HELP ME)

JEDEC Jedi

Re: Crucial MX300 SDD - Windows 10 Freezing (HELP ME)


DMO wrote:

I have enabled virtual memory of min 300 max 4000 MB - but only on my second drive - ie not on the SSD.

I'm wondering if it would be better to enable virual memory on my SSD rather than on my second HD, since it is a faster drive (allegedly)


Personally I always leave the paging file on the SSD. You can try to enable it on the SSD rather than on HDD, if it would help with your issue that would be great :-) And you don't have to worry about SSD lifespan. Modern SSDs endurance isn't an issue for most users. Rated wear wise my 128GB M4 from 2012 should work by 2092 Smiley LOL

 

Intel Driver Update utility offers chipset driver - you could try to install it but I would try storage driver first. 

As for the storage drivers, you can download them with the links I have posted before or directly from Intel - 11.2.0.1006 or 10.1.0.1008 - don't worry about the names or descriptions, the drivers are unified and on supported chipsets they should work on anything from XP to W10. I have been using this 11.2 driver on my 2007 notebook and it has been working flawlessly. You are righ that something can possibly go wrong during driver installation. I have never encountered any serious issues but in order to be on the safe side you could do data backup before driver installation.

 

You download small 64bit Intel RST AHCI driver file, unzip it and install the driver files through Device manager -> IDE ATA/ATAPI Controllers (or Storage Controllers) -> right click on the selected controller -> Properties -> Driver tab -> Update Driver -> Browse my computer for driver software

Anyway that's what I have been doing on old notebooks after finding proper driver Smiley Happy

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

DMO
Binary Boss

Re: Crucial MX300 SDD - Windows 10 Freezing (HELP ME)

Thank you bogdan.

You have gone well beyond the call of duty!

I shall take your advice.

As it happens I'm in the process of backing up at the moment - though come to think of it that's a bit silly as I still have my original HD and I have important stuff from HD1 in the Cloud anyway.

I'll let you know how I got on and whether it made any difference in due course.

Best

David

DMO
Binary Boss

Re: Crucial MX300 SDD - Windows 10 Freezing (HELP ME)

Oops!

Under IDE ATA/ATAPI controllers I have

ATA Channel 0 (which I guess is HD0 - the new SSD)

ATA Channel 1

Intel ICHM Ultra ATA Storasge Controllers

Standard SATA AHCI Controller

 

I suspect it is one of the latter two I need to update/replace - and I suspect it is the Intel one.

But could you please confirm this is the likely case? Then I shall follow the AHCI method described in the Readme notes...(I won't hold you responsible if things go '**bleep** up', promise!!)

Best

David

 

JEDEC Jedi

Re: Crucial MX300 SDD - Windows 10 Freezing (HELP ME)

Yeah, try the Intel ICHM or standard AHCI controller. It shouldn't install if you choose wrong ;-) And I think that after driver instalattion all those devices should be replaced by just one entry, something like 'Intel Mobile Express Chipset SATA RAID Controller' perhaps.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

DMO
Binary Boss

Re: Crucial MX300 SDD - Windows 10 Freezing (HELP ME)


bogdan wrote:

Yeah, try the Intel ICHM or standard AHCI controller. It shouldn't install if you choose wrong ;-) And I think that after driver instalattion all those devices should be replaced by just one entry, something like 'Intel Mobile Express Chipset SATA RAID Controller' perhaps.


Well done bogdan

It only let me replace the Standard SATA AHCI Controller claiming the other was up to date. But the ex-Standard Controller now reads Intel ICH8M-E/M SATA AHCI Controller dated 2010 rather than 2006.

I have now disabled Momentum Cache and removed the virtual memory on HD1, leaving it only on the SSD.

We shall see if this stops the freezing during the course of today.

Thank you for all your help. If it works, it works. If it doesn't - well, such is life. I don't think there is anything more that can be done.

Best wishes

David

DMO
Binary Boss

Re: Crucial MX300 SDD - Windows 10 Freezing (HELP ME)

[ Edited ]

bogdan wrote:

Yeah, try the Intel ICHM or standard AHCI controller. It shouldn't install if you choose wrong ;-) And I think that after driver instalattion all those devices should be replaced by just one entry, something like 'Intel Mobile Express Chipset SATA RAID Controller' perhaps.


I think I can now safely say that my problem has been solved by your suggestions bogdan. I can (not that I would normally want to...) safely run Firefox and Google Chrome at the same time, both with mutiple tabs without encountering a total freezup of the machine without Momentum Cache on. Whereas before the machine would freeze even without a browser open, just by checking a setting, unless I had Momentum Cache turned on. And as Momentup Cache needs to use a substantial minority of my limited RAM, I think I shall leave it off.

I cannot thank you enough.

Best Regards

David

Bit Baby

Re: Crucial MX300 SDD - Windows 10 Freezing (HELP ME)

thanks I unistall Acronis and there is freezing problem until now. Guillermo

Bit Baby

Re: Crucial MX300 SDD - Windows 10 Freezing (HELP ME)

thanks I unistall Acronis and there is freezing problem until now. Guillermo

DMO
Binary Boss

Re: Crucial MX300 SDD - Windows 10 Freezing (HELP ME)

@gmazocar Try bogan's suggestions. Worked for me. (And do read all the posts)
Bit Baby

Re: Crucial MX300 SDD - Windows 10 Freezing (HELP ME)

  1. Having the exact same issue here. I hate to sound like I am parroting someone else's issue but, word-for-word, these are the Crucial issues I am having with the exact same drive. Crucial can’t be ignorant of something like this happening to multiple users.