Crucial SSD 1Tb crashing in Macbook Pro

Kilobyte Kid

Crucial SSD 1Tb crashing in Macbook Pro

I bought a Crucial MX300 2.5-inch 1Tb SSD for my Macbook Pro Mid 2012 a couple of months ago. Since I have installed it, the computer does not boot properly. It takes too long to find the initializing disk (which in the case is the SSD) and it does not find all the times, so I have to be restarting the computer several times.  When I changed the SSD with my old HD, it worked fine. I have also tried to use my friend's SSD (which is from another brand) and it worked fine. My SSD is within the warranty time, so I really would like to solve this issue as soon as possible, because I work with my computer. 

1 Reply
Community Manager

Re: Crucial SSD 1Tb crashing in Macbook Pro

@MariaAugusta I am sorry for the issues that you have experienced with your SSD. It sounds like it may be a bad ribbon cable that connects from the logic board to the SSD. It's not unusual for issues with this cable with new SSDs, but that it still may work with another SSD or old HDD. This simplest and only real way to test if the cable is defective, would be by removing the SSD from the Macbook Pro, and testing it in a different environment. The easiest way to test externally is by connecting the SSD via some sort of external USB enclosure or cable. If you test it and the drive works fine in another environment it would point to the cable being the issue. We would advise replacing this cable and see if the issue resolves. You may find this cable at iFix or OWC. Please let us know if you have any other questions or concerns. 

YogiH, Crucial Moderator, US

How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?