Crucial Storage Executive fails after splash screen

Kilobyte Kid

Crucial Storage Executive fails after splash screen

Hi, As the title says, the program won't start up. It just disappears after the splash screen with no trace in task manager or any errors. I read somewhere that ramdisk could affect (I did install it to transfer chrome's cache to it to avoid unnecesssary SSD writes on my mx300 M2). Anyway, turning the ramdisk off momentarily allows the program to run. Turning it on again leads to the save behaviour mentioned earlier, splash screen with nothing thereafter.

 

Any idea why this happens? It's quite a nuisance. Thank you.

1 Reply
JEDEC Jedi

Re: Crucial Storage Executive fails after splash screen

[ Edited ]

Storage Exec ships with Crucials own ram caching software, Momentum.  Perhaps there's some conflict with that.  You could use it instead but it is an automatic caching solution rather than a manually configured RAM disk.

 

For what it's worth, I use Chrome with no RAM caching or drives and my 2 year old MX200 still has 96% of its life left.  You may be over-estimating the effect a browser cache will have on a modern SSD!  It was something to worry about on SSD's from several years ago but these days you could almost argue that if you're going to this much unneccasary trouble, shutting it down for the sake of a firmware update isn't much extra trouble. Smiley Happy  Hopefully Crucial will fix it in a future version of Storage Exec for you.

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?