Dead MX200

Bit Baby

Dead MX200

I recently formatted my MX200 500 gb in preperation to do a full system reset and install additional drives. After the format I can no longer find my drive anywhere both on mac and windows based systems?

 

I have tried moving the drive to an external housing with usb 3 and so far no disk utility or disk part can see the device?

 

Im not worried about the files on the drive as I have backups so i deally i just want to get it back to being a usable drive rather than buy new?

7 Replies
JEDEC Jedi

Re: Dead MX200

Do you mean 'format' (as you say) or do you mean secure erase?  If you secure erased it then it won't have a file system and you'll need to re-initialise the disk.  In Windows, this is done from control panel -> admin tools -> computer management -> disk management.

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
JEDEC Jedi

Re: Dead MX200

If it is as targetbsp suggests, then for a Mac you need to launch Disk Utility and either create a parition or erase the drive.  High Sierra Disk Utility has a bug/feature where it does not show blank drives by default.  You need to change the setting to "Show all devices", then quitting & relaunching Disk Utility.   Disk Utility can be accessed from the OSX installer by launching it from the Tools or Utilities menu within the installer.   The OSX installer needs to see a valid volume on the drive before it will allow you to select it as destination. 

Bit Baby

Re: Dead MX200

Thanks for your reply!

 

Im pretty sure it was just a standard format, however I have taken your advice and checked it out. I did not manage to find the drive listed as an option on any of the admin programs. I have also loaded the crucial storage executive software to my windows machine and that can not see the drive (I had planned on trying to update the firmware) I have tried the power cycle too but I only have access to a sata to usb 3.0 reader at the minute. Im now trying to make the crucial boot disc option and see if that can see it (Both windows and mac).

 

If you have any other ideas Im game for trying!

Bit Baby

Re: Dead MX200

Thanks for your reply!

 

Im pretty sure it was just a standard format, however I have taken your advice and checked it out. It did change the view but it did not list the drive/see it. I have also loaded the crucial storage executive software to my windows machine and that can not see the drive (I had planned on trying to update the firmware) I have tried the power cycle too but I only have access to a sata to usb 3.0 reader at the minute. Im now trying to make the crucial boot disc option and see if that can see it (Both windows and mac).

 

Again If you have any other ideas Im game for trying!

JEDEC Jedi

Re: Dead MX200

Nick512,

 

What computer was the MX200 installed when you did the format? 

 

How was the SSD connected to the computer?

 

What OS you were booted to when you formatted the SSD?

Bit Baby

Re: Dead MX200

The drive was installed in a MacBook Pro (13-inch, Mid 2012)/MacBookPro9,2, connected via the internal ribbon cable to the logic board. At the time I was running OSX high sierra 10.13.?? (I cant remember what my last update was!)

 

JEDEC Jedi

Re: Dead MX200

Nick512,

Were you having any issues with the MBPro & the MX200 before you erased it?

Now we just have to figure out if you have just a blank drive, an encrypted drive, a failing drive or if you have a defective or incompatible cable/adapter.

 

Connect your SSD to your Windows PC again and follow targetbsp's instructions to see if the SSD is seen by Disk Management at all.

 

I am no longer a Windows user, so I am not as familar with how well Windows reports about connected hardware.   You could try viewing the Event Viewer logs t see if perhaps the drive is partially detected, but is throwing errors. 

 

I also find macOS is hard to use for diagnosing hardware issues. I find using a Linux Live USB/CD such as Knoppix can be very useful.  You can even boot Knoppix on your MBPro using the option boot method and it includes the necessary troubleshooting tools.  By issuing a few Linux terminal commands we can quickly determine the state of the SSD.  Let me know if you would like instructions for this option.

 

BTW, your MBPro 13" (mid 2012) model is known to have an issue with the internal hard drive cable.  They tend to have a high failure rate where Apple even had a special free replacement program for them a while back, but for most people this program has expired.  So be careful running tests on the SDD using the MBPro's internal bay as the results may not be accurate.