Enable AHCI on: m4 SSD, 100MB starting partition, Win7 64bit

Kilobyte Kid

Enable AHCI on: m4 SSD, 100MB starting partition, Win7 64bit

[ Edited ]

Dear folks,


I just got the AHCI settings unlocked in my BIOS, hence the Win7 installation happend in IDE mode...thats probably why it left me with that 100MB starting partition?


When I'm enabling AHCI now in my BIOS, it does not find / detect my SSD anymore, prompting '"No operating system found".


Any other BIOS settings which I have to change? Is it the fault of that starting partition? Do I need to secure erase and set up a new system??

I'm using the newest firmware by the way.


Grateful for any recommendations!

Cheers and have a nice day

19 Replies

Re: Enabel AHCI on: m4 SSD, 100MB starting partition, Win7 64bit

Windows 7 setup makes the 100mb partition. it's where it keeps its boot files.  It has nothing to do with ahci/ide.

To switch to AHCI, you need to make this change whilst still in IDE: http://support.microsoft.com/kb/922976

Then switch to AHCI.


But I have to say, the error you're getting suggests it isn't getting that far.  You didn't delete the 100mb partition did you?  That would cause you issues!

How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: Enable AHCI on: m4 SSD, 100MB starting partition, Win7 64bit

[ Edited ]

Indeed, I did that before, but it's not connected to the actual problem that the BIOS does not detect the SSD anymore after enabling AHCI.


I found a thread in a ***Edited to remove Crucial competitor*** forum, where they recommended to secure erase and set up a new system...somehow they brought that into connection with that 100MB partition...

I did not touch that partition...everything just works fine when I set the AHCI to disabled.


Confusing, ey?


PS: just booted with PartedMagic, it found and also could access the drive! --> ???

the smartmontools stated this:

Device Model:     M4-CT128M4SSD2
Serial Number:    **********
LU WWN Device Id: *************
Firmware Version: 0309
User Capacity:    128,035,676,160 bytes [128 GB]
Sector Size:      512 bytes logical/physical
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   8
ATA Standard is:  ATA-8-ACS revision 6
Local Time is:    Fri Mar 16 15:26:06 2012 UTC
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

SMART overall-health self-assessment test result: PASSED

I was able to mount it and save this report file.

What the heck is going on there? Smiley Happy

Memory Hawg

Re: Enable AHCI on: m4 SSD, 100MB starting partition, Win7 64bit

So, if you swtich it back to IDE mode does it work correctly?


This may be why it's not working in AHCI mode, you said "just got the AHCI settings unlocked in my BIOS"  What do you mean by that, did someone modify a BIOS for you?   If so, they may have done the mod incorrectly.  What motherboard are you using, with what BIOS version.


Also, often when you swtich SATA modes in the BIOS, you need to reboot back to the BIOS and find the Hard Disk Boot Priority menu and move your OS drive back to the top of that list.   This is not the same setting as 1, 2, 3, or first second, third boot order, it's a totally different setting / menu that allows you to move hard drives or USB drives around in a booting order, and you want to be sure your main OS drive is at the top of this list.  This could be the issue if you are not using a modified BIOS, so please look through your BIOS for this list and move your drive to the top if it's not already there.

Kilobyte Kid

Re: Enable AHCI on: m4 SSD, 100MB starting partition, Win7 64bit

Thanks for your advice!


Yep, if I switch back to IDE there are no problems at all. Except of a non-functioning TRIM.


And  yes, I got the BIOS of my 2007 HP Laptop unlocked..not really "modified" I think...because as I have understood it so far, the functions where all there but just trimmed by HP...?


I already asked the unlockers if there could be a possibilty of having forgottten to unlock that BOOT-order BIOS-option you were talking about. I searched for it and all there was and is are the standard boot-order settings about "HDD, CDROM, USB, NETWORK" etc..,  but no special option to give an order to the 4 SATA ports....

Memory Hawg

Re: Enable AHCI on: m4 SSD, 100MB starting partition, Win7 64bit

[ Edited ]

Where did you get the modified BIOS?   I still think this may be the issue, they may not have done it correctly, or it may not be possible to use this setting even if enabled - which anyone that modifies a BIOS wouldn't be able to test before giving you the file unless they also had that same machine there.


So it may just be the mod was done correctly, but the function cannot be enabled anyway, meaning only the setting can be made visible but still be non-functional. Did they say they know others that they modified AHCI in this same system BIOS and it worked, if so did they show you those threads?


What is the exact model of this system, I'll see if the chipset is even AHCI capable, if it's ICH 7 then I can tell you now it's not for sure no matter what anybody does to your BIOS!





Kilobyte Kid

Re: Enable AHCI on: m4 SSD, 100MB starting partition, Win7 64bit

Thanks for your effort!


I got the BIOS here, and this is also my thread:


I think there have been no previous experiences concerning that issue.


And sorry, I was thinking that I've mentioned the chipset details before:

CPU-Z gives me the following info:

Northbridge NVIDIA nForce 520 rev. A3
Southbridge NVIDIA ID0442 rev. A3

DMI Baseboard
vendor Quanta
model 30D0
revision 85.26

0x045D MCP65 SATA Controller(IDE mode) 0x10DE
0x0448  MCP65 PATA Controller 0x10DE



Memory Hawg

Re: Enable AHCI on: m4 SSD, 100MB starting partition, Win7 64bit

OK, thanks!   Those guys know what they are doing usually, so I doubt it's a modification error, and I see your chipset does support AHCI.   So, while looking around I see many threads on the Nforce drivers being the cause of AHCI issue, as it they don't work without being a modified version.


So, please try these drivers for now, then enable AHCI again, and if these work for you then I'll try to find you a newer version


And to swtich from IDE to AHCI you may need to do a clean install, otherwise you will be greeted with the 0x0000007b BSOD at startup


If you are currently using MSAHCI drivers you should be OK switching to AHCI, but you will need to make the following registry changes first


Enable switching between all IDE/AHCI/RAID modes by changing "Start" Values in these keys to 0 (Win 7 / Vista ONLY)

Kilobyte Kid

Re: Enable AHCI on: m4 SSD, 100MB starting partition, Win7 64bit

[ Edited ]

I've downloaded those Fernando-drivers for my Win7 64bit (actually) already, but I did not install them yet.

And except for that Pciide\Start value, I've changed the others already to 0.


To get some serenity about the nForce driver, I've opened up a post over here:


No replies yet...


Anyway...how would these advices let my BIOS detect the SSD properly?

Oh, and if I boot with PartedMagic LiveCD, it detects and mounts the SSD if AHCI is enabled! But I dont know how to find out if AHCI is really "translated" by the linux OS then...


Cheers and have a great week!


PS: Just checked the Pciide reg-value: its already set to 0, I didn't touch it.

Memory Hawg

Re: Enable AHCI on: m4 SSD, 100MB starting partition, Win7 64bit

I would make a image based backup, then install those Nfore drivers and see if it helps or not.  If not restore the backup


As for the linux thing, I'm not sure if that matters, or if it actually boots AHCI?  Can you run AS SSD there?  If so that will tell you what driver is used, or maybe whatever linux equivalent for device manager might show what driver is being used, then you could google that and see if it's AHCI or IDE based driver