Feedback Thread Firmware M0CR040 for the MX300

Bit Baby

Re: Feedback Thread Firmware M0CR040 for the MX300

[ Edited ]

Hi, I receieved my MX300 525GB yesterday and tried to update to the latest firmware with the Crucial Storage Executive app. The app recognize the SSD fine but when I try to update the firmware and check the option to live update (without reboot) it kinda goes though and says it was successful but it's not really. It's still the same firmware version as befor, which is not M0CR040. I found a .ISO that I could burn  and boot on it but I my DVD-Burner is bad and I have no blank CD. The disk is in an external enclosure, it's not my system SSD (yet), therefore there should be no need to boot from a CD to do that. I see that I have the option of choosing a pre-downloaded firmware .zip file locally. The problem is that i've searched everywhere and cannot find that .zip file with the actual firmware, the only thing I can find is a that bootable ISO image.

Anybody know eher to find that firmware file?

I'll try to create a bootable USB thumbdrive instead of a CD, but if someone could give me a link for the .zip file I would prefer that.


Thanks!

JEDEC Jedi

Re: Feedback Thread Firmware M0CR040 for the MX300

As far as I know Crucial doesn't provide such zip files that could be used with Storage Executive. It is a little bit weird since micron (parent company) has them for their SSD models.

 

Try to make bootable USB thumbdrive - UUI always worked for me but in case of any troubles with botting you can also try UNetbootin or Rufus.

Since you wrote that you are using external enclosure note, that firmware update won't work over USB.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Kilobyte Kid

Re: Feedback Thread Firmware M0CR040 for the MX300

[ Edited ]

Hello,

 

My 750GB MX300 speed has slowed after updating M0CR040.

 

I've got this model on BlackFriday, at first there was no problem definitely when the frimware was M0CR011.

 

My system is ThinkStation, which has Xeon E5-V3, C612 mainboard.

 

The most serious thing is a result from AS SSD Benchmark.

 

 

p.s. I've got the benchmark result of normal SSD (same model, mx300 750gb) from a  review site.

 

SSD_Issues_resized.jpg

Bit Baby

Re: Feedback Thread Firmware M0CR040 for the MX300

I just bought the MX300 and installed it my late 2007 iMac.

Is this firmware update necessary? I mean does it fix some critical issues? Or for the time being can I just leave it as is?

(I'm hesitating, because it is a bit more complicated to perform the update on a Mac)

Kilobyte Kid

Re: Feedback Thread Firmware M0CR040 for the MX300

[ Edited ]

Hey guys, 

 

I hope it's ok to post a screenshot here.

 

So I received my MX 300 (275 GB) today and tried to update but always I get an error with status 8. I don't understand what might go be wrong because everything seemed to work fine until this happens

 

The program is in German but I think you can recognize the important text (which is in English, Fehler means Error btw).

 

Thanks a lot!

 

 

 

Edit: You can right-klick the image and show it in a new tab to view in full size

 

Bit Baby

Re: Feedback Thread Firmware M0CR040 for the MX300

[ Edited ]

Hi,

After applying this update i cant boot to windows 10 (inaccesible boot device).

I can see all my files on c:,but can not boot.

Any help please

Thanks

JEDEC Jedi

Re: Feedback Thread Firmware M0CR040 for the MX300

Take a look at this thread.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Kilobyte Kid

Re: Feedback Thread Firmware M0CR040 for the MX300

thanks for your reply, i dont mind the regular performance of ssd but i cant get "high performance" like samsung's RAPID MODE. 

Over-Provisioning and momentum cache settings are open and optimized at %10. is there any other settings? lenovo drivers up to date but... i dont know :/

Binary Boss

Re: Feedback Thread Firmware M0CR040 for the MX300

[ Edited ]

Hi, I am having the freezing issue with the 2TB Crucial MX300 my chipset is  Intel® HM77 Chipset and I explain the issue in more detail in my post: http://forum.crucial.com/t5/Crucial-SSDs/Issue-with-SSD-freezing/m-p/177330

Essentially I have tried everything except for installing the intel RST because I am not sure of which version is right for me and all the ones I downloaded are incompatible saying " this platform is not supported". The new firmware update did not fix my issue at all. 

JEDEC Jedi

Re: Feedback Thread Firmware M0CR040 for the MX300


algebram wrote:

thanks for your reply, i dont mind the regular performance of ssd but i cant get "high performance" like samsung's RAPID MODE. 

Over-Provisioning and momentum cache settings are open and optimized at %10. is there any other settings? lenovo drivers up to date but... i dont know :/


You can set high performance via control panel -> power options. Then click 'show additional plans'

 

The actual hardware manufacturer will generally have more up to date drivers than the computer manufacturer because computer manufacturers never bother providing newer versions once they replace a model.  ie. Intel will have newer storage drivers than Lenovo.

However, Intel will also eventually leave hardware behind.  So you may find the newest ones aren't compatible with your system, but they may have older ones, that are still newer than Lenovo's, that are.

______________________________________

Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!