Feedback Thread Firmware M0CR060 for the MX300

Community Manager

Feedback Thread Firmware M0CR060 for the MX300

Firmware revision M0CR060 for the Crucial MX300 (all form factors) is now available. This firmware update applies to the MX300 SSD (all form factors), and should not be applied to any other Crucial SSD model. Currently, the firmware update is available through the Crucial Storage Executive and through a manual boot file found here:


http://www.crucial.com/support/firmware.aspx

Release Date: 9/12/2017

  • SMART Attribute 198 was not reset at start of each background scan
  • Improved compatibility with Micron JMB394 RAID controller
  • Improved drive error handling
  • Disable APM
  • General stability improvements
  • Second source enablement
YogiH, Crucial Moderator, US


________________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
7 Replies
DMO
Kilobyte Kid

Re: Feedback Thread Firmware M0CR060 for the MX300

I have successfully updated my MX300 firmware with M0CR060 on my Windows machine, via Storage Executive. Unfortunately I cannot update the MX300 SSD on my Linux (Ubuntu 17.04) machine, using the .iso image written to my usb stick - though I did successfully manage to do so with the previous firmware update. So I'm wondering whether I am doing something wrong this time, or the .iso is just not bootable?

I've tried writing the .iso file to a Fat32 formatted usb stick using (a)Unetbootin (via the Windows machine and also via the Linux machine), b) win32DiskImager (via the Windows machine), c) UniversalUsbInstaller (via the Windows machine) - all to no avail. I've also tried changing my Linux machine's bios from uefi mode to legacy mode, playing around with secureboot/no secureboot - also all to no avail.

Yet I know I succeeded with the previous update. So what has changed? Or what might I have forgotten?

Thanks

David

Kilobyte Kid

Re: Feedback Thread Firmware M0CR060 for the MX300

[ Edited ]

I'm running Storage Executive 3.46 and was on Firmware M0CR040 and just upgraded sucessfully thru Storage Executive to M0CR060. There were two steps that I took that I thought would help to make this successful and that was stopping Momentum Cache and in Configuration System; Hide MS Services; and Disabled all other Services and rebooted. After performing these steps I then went into Storage Executive and performed the Firmware Update. 

 

The computer rebooted and came up into a blue Crucial screen and it began to perform the upgrade showing steps and that they were successful. Once it completed it then rebooted back into Windows 10 with no problems. I then enabled all of the Services in Configuration System and rebooted. After the boot I went into Storage Executvie and turned Momentum Cache back on along with Over Provisioning at 10%. 

 

After doing this I then began checking programs and noticed that programs were popping up a littler faster than when I was on M0CR040. The computer I have is a Dell XPS 8920 Special Edition with i7 7700, 16 Gig DDR4 Ram, running Windows 10 and this machine is about two months old. With M0CR040 the best AS SSD Benchmark that I was able to achive on the over all score was 30153 and with M0CR060 I have been able to get 32662. With this benchmark it does show that it's a little better than before. 

 

I will keep testing and see if I encounter any problems and if I do I will update this information. 

 

I just updated an Alienware M17x R2 from M0CR040 to M0CR060 using the same above process and it went very smooth. I'm also seeing about the same improvement  with this computer except that it's running at SATA II instead of SATA III because of the hardware.   

Highlighted
JEDEC Jedi

Re: Feedback Thread Firmware M0CR060 for the MX300

@DMO I don't know what has changed but I would try Rufus.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Kilobyte Kid

Re: Feedback Thread Firmware M0CR060 for the MX300

Updated using ISO. No problems at all.

Bit Baby

Re: Feedback Thread Firmware M0CR060 for the MX300

Unable to create an USB stick with macOS. Tried under 10.09, 10.10, 10.11, 10.12, and 10.13 High Sierra. Disk Utility reports error : "Restore Failure : Could not validate source - Invalid argument".

My Macs have no CD-ROM reader.

A company like Crucial should be able to provide a Mac compatible procedure to update SSD firmware without using a CD-ROM (we are in 2017).

JEDEC Jedi

Re: Feedback Thread Firmware M0CR060 for the MX300

Firmware update successfully performed with 'Live update' option which doesn't require a reboot.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Bit Baby

Re: Feedback Thread Firmware M0CR060 for the MX300

I have 4 * MX300 525GB drives currently on 050

used almost only as archive drives, but need the highest read speed.

 

Better expected read speed with this update ?

Is this a Critical update or only Recomended update?