Feedback Thread Firmware MU04 for the MX200

Kilobyte Kid

Re: Feedback Thread Firmware MU04 for the MX200

[ Edited ]

Looks like the problem was with the Crucial update content site availability and not content blocking on my business network. This is because, whilst I was able to access multiple other sites without any issuees, Storage Exec update was failing, on the same day. However, when I tried today it worked perfectly. unfortunately, US based tech companies, in my experience, all too often do "out-of-hours" maintenance on their systems, neglecting the rest of the world and other timezones.

 

It also seems that, even though Storage Exec supports downloading and manually installing a firmware update, Crucial appear to be ignoring and possibly even not supporting this feature, in the Micron, rebadged software. I have a support case open to try and identify why/how/if this is the case.

JEDEC Jedi

Re: Feedback Thread Firmware MU04 for the MX200

I think they are opting for live update options and you are right that for some reason crucial does not provide firmware update packages that you could 'manually load' with storage executive. The firmware update package is small .zip file (smaller than 1MB I think) that contains firmware .bin file and some other firmware.properties file.

 

But you can still try to manually update the firmware with manual boot files (for bootable thumbdrives) that crucial provide.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Bit Baby

Re: Feedback Thread Firmware MU04 for the MX200

HI 

 

I am using mx200(500G) on the Mac system, OS 10.12(Sierra), Mac mini(late2012). 

 

After upgrading the firmware to MU04, the writing speed of this one has fallen to half speed around 250. 

 

Would you please check the compatibility with Mac system? 

 

And i don`t usually use TRIM function but i believe the G.C function on the mx200. 

 

i hope you will check G.C function on the Mac system as well. 

 

Thank you!

JEDEC Jedi

Re: Feedback Thread Firmware MU04 for the MX200

[ Edited ]

When you say it's halved, do you mean you did a before and after test? or are you saying you benched it after the firmware update and it's half what it was when the drive was new?

 

Because if it's the latter, a regular Mac poster on here reckons you need trim under MacOS to maintain full write speed.  So the drive could just be 'dirty'

______________________________________

Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Kilobyte Kid

Re: Feedback Thread Firmware MU04 for the MX200

after upgrade to MU04

 

Linux 4.8.6-1 #1 SMP Mon Oct 31 21:07:35 CET 2016 x86_64 AMD_FX(tm)-8320_Eight-Core_Processor PLD Linux

 

[    1.579862] ata1: SATA max UDMA/133 abar m1024@0xfd30b000 port 0xfd30b100 irq 19
[    2.052533] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    2.052789] ata1.00: supports DRM functions and may not be fully accessible
[    2.053626] ata1.00: ATA-10: Crucial_CT250MX200SSD1, MU04, max UDMA/133
[    2.053628] ata1.00: 488397168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[    2.054713] ata1.00: supports DRM functions and may not be fully accessible
[    2.057065] ata1.00: configured for UDMA/133
[    2.183468] ata1.00: Enabling discard_zeroes_data
[    2.183809] ata1.00: Enabling discard_zeroes_data
[    2.184365] ata1.00: Enabling discard_zeroes_data
[   35.151337] ata1.00: supports DRM functions and may not be fully accessible
[   35.153198] ata1.00: supports DRM functions and may not be fully accessible
[   35.155413] ata1.00: configured for UDMA/133
[   35.155416] ata1: EH complete
[   35.223845] ata1.00: Enabling discard_zeroes_data

 

[    1.579864] ata2: SATA max UDMA/133 abar m1024@0xfd30b000 port 0xfd30b180 irq 19
[    2.052550] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    2.052851] ata2.00: supports DRM functions and may not be fully accessible
[    2.053685] ata2.00: ATA-10: Crucial_CT500MX200SSD1, MU04, max UDMA/133
[    2.053686] ata2.00: 976773168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[    2.054862] ata2.00: supports DRM functions and may not be fully accessible
[    2.057233] ata2.00: configured for UDMA/133
[    2.183489] ata2.00: Enabling discard_zeroes_data
[    2.183730] ata2.00: Enabling discard_zeroes_data
[    2.185379] ata2.00: Enabling discard_zeroes_data
[   35.177908] ata2.00: supports DRM functions and may not be fully accessible
[   35.179764] ata2.00: supports DRM functions and may not be fully accessible
[   35.181984] ata2.00: configured for UDMA/133
[   35.181987] ata2: EH complete
[   35.250527] ata2.00: Enabling discard_zeroes_data

 

speed link donwgrade to 3.0Gbps

 

 

howto downgrade firmware to MU03 ?

 

Kilobyte Kid

Re: Feedback Thread Firmware MU04 for the MX200

I don't know whats hapen, but works Smiley Happy)

 

[    1.573027] ata1: SATA max UDMA/133 abar m1024@0xfd30b000 port 0xfd30b100 irq 19
[    2.046754] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    2.046997] ata1.00: supports DRM functions and may not be fully accessible
[    2.047839] ata1.00: ATA-10: Crucial_CT250MX200SSD1, MU04, max UDMA/133
[    2.047840] ata1.00: 488397168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[    2.049114] ata1.00: supports DRM functions and may not be fully accessible
[    2.051614] ata1.00: configured for UDMA/133
[    2.194321] ata1.00: Enabling discard_zeroes_data
[    2.194687] ata1.00: Enabling discard_zeroes_data
[    2.195155] ata1.00: Enabling discard_zeroes_data
[   28.956642] ata1.00: supports DRM functions and may not be fully accessible
[   28.958495] ata1.00: supports DRM functions and may not be fully accessible
[   28.960724] ata1.00: configured for UDMA/133
[   28.960727] ata1: EH complete
[   29.027247] ata1.00: Enabling discard_zeroes_data

 

[    1.573028] ata2: SATA max UDMA/133 abar m1024@0xfd30b000 port 0xfd30b180 irq 19
[    2.046725] ata2: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    2.046974] ata2.00: supports DRM functions and may not be fully accessible
[    2.047900] ata2.00: ATA-10: Crucial_CT500MX200SSD1, MU04, max UDMA/133
[    2.047902] ata2.00: 976773168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[    2.049106] ata2.00: supports DRM functions and may not be fully accessible
[    2.051478] ata2.00: configured for UDMA/133
[    2.194341] ata2.00: Enabling discard_zeroes_data
[    2.194596] ata2.00: Enabling discard_zeroes_data
[    2.196086] ata2.00: Enabling discard_zeroes_data
[   28.984805] ata2.00: supports DRM functions and may not be fully accessible
[   28.987302] ata2.00: supports DRM functions and may not be fully accessible
[   28.989510] ata2.00: configured for UDMA/133
[   28.989514] ata2: EH complete
[   29.037224] ata2.00: Enabling discard_zeroes_data

 

Today, i power on pc and i see you it's ok.

Kilobyte Kid

Re: Feedback Thread Firmware MU04 for the MX200

still the same problem

 

random

[ 2.050223] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 2.050460] ata1.00: supports DRM functions and may not be fully accessible
[ 2.051322] ata1.00: ATA-10: Crucial_CT250MX200SSD1, MU04, max UDMA/133

 

[ 2.050205] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 2.050454] ata2.00: supports DRM functions and may not be fully accessible
[ 2.051333] ata2.00: ATA-10: Crucial_CT500MX200SSD1, MU04, max UDMA/133

 

to 6.0Gpbs

 

how to downgrade to MU03 ?

 

Bit Baby

Re: Feedback Thread Firmware MU04 for the MX200

[ Edited ]

*SOLVED*

I have a new MX200 w/ firmware MU03. I installed the latest version of Storage Executive which reports MU03 as the latest firmware update; however, the website shows MU04 as the latest update. Please Advise.

 

Solution: The MU04 firmware finally showed up in Storage Executive after a few hours. And, it installed perfectly using my Sabrent DS-USB31 dock. I was then able to use the included Acronis app to clone a hard drive to the MX200.  As I write this update, I'm using the MX200 as my boot drive. Smiley Very Happy

JEDEC Jedi

Re: Feedback Thread Firmware MU04 for the MX200

Someone reported the same issue in this thread: http://forum.crucial.com/t5/Crucial-SSDs/Feedback-Thread-Firmware-M0CR040-for-the-MX300/td-p/176660/...

 

Looks like it's gone AWOL from Storage Exec but still avavilable for manual installation via the link I posted in the above thread.

______________________________________

Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!