Feedback Thread Firmware MU05 for the MX200 and MU03 for the MX100

JEDEC Jedi

Re: Feedback Thread Firmware MU05 for the MX200 and MU03 for the MX100

 @djoser,   Using Linux run the following command on the Crucial firmware .iso file before using "dd" to burn it to the USB drive:

isohybrid   <path-to-firmware-updater>/MX200_MU05_Update.iso

I believe the isohybrid command is part of the syslinux-utils package on Debian based distributions.

 

The isohybrid command makes the ISO image into a hybrid image which can be burned to either a CD or a USB drive.   This particular image only boots using MBR so you will likely need to enable legacy boot options in the BIOS/UEFI settings.    This procedure works for many of the Crucial firmware updaters.

Highlighted
Kilobyte Kid

Re: Feedback Thread Firmware MU05 for the MX200 and MU03 for the MX100

Hi there!

Thank you for your answer and providing a possible solution.

I followed your instructions, but unfortunately it didn't work. I was not able to create a bootable usb device to do the firmware upgrade.

I think the basic problem is that the iso provides only MBR.

The BIOS of my mainboard (Asrock J5005-ITX) has no option to activate booting from legacy usb, it seems to be UEFI only.

 

Cheers, djoser.

JEDEC Jedi

Re: Feedback Thread Firmware MU05 for the MX200 and MU03 for the MX100

@djoser,   I believe it may be possible to modify the updater to boot to a UEFI only system.   I'll see if I can make a little time to try it out.

 

Since you are using Linux, I believe you can make a flash drive using GRUB2 to boot the  .iso file itself.    I've seen info on this but never tried it.   I also don't know if it will work on a UEFI only system.

Kilobyte Kid

Re: Feedback Thread Firmware MU05 for the MX200 and MU03 for the MX100

Hi HWTech,

 

thank you so much for your time and efford regarding this matter.

That's what i call real support from a company, even if the product is fairly old.

Let me know, if you figured someting out!

 

Thanks again and best regards,

djoser.

Bit Baby

Re: Feedback Thread Firmware MU05 for the MX200 and MU03 for the MX100

Hello,

First i have an error of loop for the installation of the update of firmware of MU05, but i find a solution, for Debian-like i use this site:

http://guillaumeplayground.net/update-crucial-ssd-firmware/

1) first go to the offcial site of crucial:

http://www.crucial.fr/fra/fr/aide-ssd-firmware

2) unzip the archive in the folder you wish : unzip MX200_MU05_Update.zip ---> MX200_MU05_Update.iso

3) for http://guillaumeplayground.net/update-crucial-ssd-firmware/ --> download : crucial-fw.tar.gz ---> tar xjf crucial-fw.tar.gz

4) A folder will be create : crucial-fw

5) navigate to the new folder "crucial-fw" --> and ./crucial-fw.pl

6) It could be some problems with archive dependancy when you use this script ---> cpan -i Archive::Extract

7) The script crucial-fw.pl --> it will download iso for many type of ssd from crucial and not necessary .iso (old) for us in /boot/crucial-fw/ ---> this folder is not necessary : /boot/crucial-fw

8) You can erase this folder cd /boot; rm -rf crucial-fw/

9) create in / , a folder like --> cd /; mkdir isos

10) read point 2) --> in folder of ...---> mv MX200_MU05_Update.iso /isos

11) edit --> vim /etc/grub.d/45_crucial-fw

12) when editing --> modify the line :

      - line menuentry ... ---> menuentry "MX200_MU05 FW"

And

      - set isofile...  ---> set isofile="/isos/MX200_MU05_Update.iso" (where the your iso is, mine is in /isos/, read point 10)

13) Verify the right of /isos/MX200_MU05_Update.iso (640, for mine)

14) update the grub --> update-grub

15) Verify there is no errors when updating the grub.

16) Reboot

17) When the grub apaers --> the Submenu show --> Crucial Firmware Update --> Select it -->  MX200_MU05 FW, select

18) Let do the process, when it install, it may be problem of reboot when the process is finish, reboot your computer.

19) You can control with hdparm -I /dev/sda --> Firmware Revision: MU05

 

Have a nice day

Good luck.

 

Bit Baby

Re: Feedback Thread Firmware MU05 for the MX200 and MU03 for the MX100

Hello,

First i have an error of loop for the installation of the update of firmware of MX200, MU05, but i find a solution, for Debian-like i use this site:

http://guillaumeplayground.net/update-crucial-ssd-firmware/

1) first go to the offcial site of crucial:

http://www.crucial.fr/fra/fr/aide-ssd-firmware

2) unzip the archive in the folder you wish : unzip MX200_MU05_Update.zip ---> MX200_MU05_Update.iso

3) for http://guillaumeplayground.net/update-crucial-ssd-firmware/ --> download : crucial-fw.tar.gz ---> tar xjf crucial-fw.tar.gz

4) A folder will be create : crucial-fw

5) navigate to the new folder "crucial-fw" --> and ./crucial-fw.pl

6) It could be some problems with archive dependancy when you use this script ---> cpan -i Archive::Extract

7) The script crucial-fw.pl --> it will download iso for many type of ssd from crucial and not necessary .iso (old) for us in /boot/crucial-fw/ ---> this folder is not necessary : /boot/crucial-fw

8) You can erase this folder cd /boot; rm -rf crucial-fw/

9) create in / , a folder like --> cd /; mkdir isos

10) read point 2) --> in folder of ...---> mv MX200_MU05_Update.iso /isos

11) edit --> vim /etc/grub.d/45_crucial-fw

12) when editing --> modify the line :

      - line menuentry ... ---> menuentry "MX200_MU05 FW"

And

      - set isofile...  ---> set isofile="/isos/MX200_MU05_Update.iso" (where the your iso is, mine is in /isos/, read point 10)

13) Verify the right of /isos/MX200_MU05_Update.iso (640, for mine)

14) update the grub --> update-grub

15) Verify there is no errors when updating the grub.

16) Reboot

17) When the grub apaers --> the Submenu show --> Crucial Firmware Update --> Select it -->  MX200_MU05 FW, select

18) Let do the process, when it install, it may be problem of reboot when the process is finish, reboot your computer.

19) You can control with hdparm -I /dev/sda --> Firmware Revision: MU05

 

Have a nice day

Good luck.

 

Kilobyte Kid

Re: Feedback Thread Firmware MU05 for the MX200 and MU03 for the MX100

I'm currently unable to update the firmware for MX100 ssd to MU03. If I try using the automated tool in Storage Executive I get "No drives need this firmware update, No drives needing update discovered". I also noticed that where it states New Firmware Update Available it shows "This will update the firmware on each M510 drive in the system.". I downloaded the MX100_MU03_Update.zip and tried to upload it using Storage Executive and I get the following error: "Uploaded file does not appear to be a valid firmware update package". I have also tried to create a bootable cdr with the iso file, but can't seem to get that to create a bootable disk at the moment. I'm running Windows 10 Pro version 1803, build 17134.48, Any help is appreciated. Thanks.

Kilobyte Kid

Re: Feedback Thread Firmware MU05 for the MX200 and MU03 for the MX100

It looks like Crucial software sees it as m510 drive. When you go to device  manager under disk drives what does it says? Like Crucial_CT512M550SSD1 (that is from my m550). Or you can check hardware (open case and see ssd label)

Just to eliminate that for start. For better advice if your drive is mx100 (i upgraded my mx100 with Storage executive reboot option) i hope you will get help.

 

Best regards

Kilobyte Kid

Re: Feedback Thread Firmware MU05 for the MX200 and MU03 for the MX100

I know that it is a MX100 drive from installing it and Device Manager also shows it as CT128MX100SSD1, and even in Storage Executive it shows the same thing. I have tried the reboot option, the no reboot option, and manually uploading through Storage Executive. The only other option that I know is to make a bootable cdr with the iso and even though I've made bootable iso's before I can't seem to figure out how to make this one bootable. Any suggestions would be appreciated.

Kilobyte Kid

Re: Feedback Thread Firmware MU05 for the MX200 and MU03 for the MX100

I finally got the firmware updated by burning the iso to a cdr(I seem to have lost my thumbdrive) and booting with it. I didn't get much sleep last night and just couldn't put together how to make a bootable cdr with the iso file, but after a nap the fog cleared and I was able to do it. I would still like to know why Storage Executive thought my MX100 was a M510?