Feedback Thread for Crucial Storage Executive, Version 3.43

Bit Baby

Re: Feedback Thread for Crucial Storage Executive, Version 3.43

Nope, one machine was upgraded, another - fresh install using bootable usb creation tool from MS. Same result - it doesn't work. Maybe you did not install some specific update that came out later for creator's?

JEDEC Jedi

Re: Feedback Thread for Crucial Storage Executive, Version 3.43

[ Edited ]

raendor wrote:

Nope, one machine was upgraded, another - fresh install using bootable usb creation tool from MS. Same result - it doesn't work. Maybe you did not install some specific update that came out later for creator's?


I religiously install all updates for everything. Smiley Very Happy

______________________________________

Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Bit Baby

Re: Feedback Thread for Crucial Storage Executive, Version 3.43

[ Edited ]

This new edition doessn't recognize any of the drives, including the Crucial MX300, in my PC running Windows 10. Happened before crator's update. Contacted customer support a few times with no reply. [Edited per Guidelines]

Bit Baby

Re: Feedback Thread for Crucial Storage Executive, Version 3.43

Hello. The latest version of Storage Executive does not detect my MX300.

I'm running AMD's new AM4 platform. The CPU is Ryzen 5 1600, and the motherboard is Gigabyte GA-AB350M-D3H.

The SSD is connected to one of the "APU" SATA socket, not the chipset SATA sockets.

I have updated the firmware successfully, and the SSD runs just fine, but the software still doesn't detect it. :/