Showing results for 
Search instead for 
Do you mean 
Reply
byh
Kilobyte Kid
byh
Posts: 5
Registered: ‎03-03-2014
0
Accepted Solution

M500 SSD Not Recognized by Windows 7 Installation on Lenovo G450

I'm using a laptop lenovo g450 20022, HDD is on windows 7 home sp1 32bit. Bios can identify the drive but does not show up in windows 7 installation drive option. Didnt matter whether it was connected to the PCI slot for the dvd writer, the hdd slot or via a sata to usb adapter through usb 2.

 

Cleaned SSD using diskpart. Not sure what else to do...

 

Could use some help please. Thank you.

Specs of the G450: http://forums.lenovo.com/t5/Lenovo-3000-and-Essential/UPGRADING-PARTS-LENOVO-G450-20022/td-p/1209832

 

JEDEC Jedi
bogdan
Posts: 1,551
Registered: ‎09-26-2012
1

Re: M500 SSD Not Recognized by Windows 7 Installation on Lenovo G450

It may be necessary to have possibly most current BIOS, did you check for BIOS update for your laptop? Is the SATA controller set to AHCI in the BIOS?

Also I would try to load storage driver (with "Load Driver" button) at the "Where do you want to install Windows?" screen. Could you please check two drivers for me? :smileyhappy:

- for the first try it is 11.7.0.1013 that can be downloaded directly from Intel, then if that one would fail

- for the second try it is 11.7.4.1001 that can be downloaded from mirror site

 

You download the file, unzip the archive and copy all following files to the USB pendrive:

iaAHCIC.cat
iaAHCIC.inf
iaStorA.sys
iaStorAC.cat
iaStorAC.inf
iaStorF.sys

 

You should be able to browse for that files at the begining of installation. Take a look here - http://www.windowsreinstall.com/win7/harddrivenotseen.htm

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

byh
Kilobyte Kid
byh
Posts: 5
Registered: ‎03-03-2014
0

Re: M500 SSD Not Recognized by Windows 7 Installation on Lenovo G450

in reply to bogdan

thanks for the tips, I've made some progress by doing the following:

 

Flash my bios to the latest version 18CN44WW v2.53 from Lenovo's website

 

Didnt change the SATA controller setting as AHCI was set as the defaul.

 

Although the correct driver was selected, windows kept reporting that I did not have new devices.

 

Lo and behold, a silly trick allowed me to progress: I was advised by a friend to remove the installation USB and plugging it in before selecting the driver. It worked.

 

However....

Created a new partition, formatted it and tried to install win 7 on it. Got an error that goes:

 

Setup was unable to create a new system partition or locate an existing system partition. See the Setup log files for more information.

 

when i unplugged the installation USB I was given this error:

 

Windows cannot be installed to this disk (show details)

Details: Windows is unable to install to the selected location. Error: 0x80300001.

 

Additional info:

Win 7 SP 1 on the read only USB in a USB 2 slot.

 

Further assistance is much appreciated.


bogdan wrote:

It may be necessary to have possibly most current BIOS, did you check for BIOS update for your laptop? Is the SATA controller set to AHCI in the BIOS?

Also I would try to load storage driver (with "Load Driver" button) at the "Where do you want to install Windows?" screen. Could you please check two drivers for me? :smileyhappy:

- for the first try it is 11.7.0.1013 that can be downloaded directly from Intel, then if that one would fail

- for the second try it is 11.7.4.1001 that can be downloaded from mirror site

 

You download the file, unzip the archive and copy all following files to the USB pendrive:

iaAHCIC.cat
iaAHCIC.inf
iaStorA.sys
iaStorAC.cat
iaStorAC.inf
iaStorF.sys

 

You should be able to browse for that files at the begining of installation. Take a look here - http://www.windowsreinstall.com/win7/harddrivenotseen.htm


 

JEDEC Jedi
bogdan
Posts: 1,551
Registered: ‎09-26-2012
1

Re: M500 SSD Not Recognized by Windows 7 Installation on Lenovo G450

[ Edited ]

I am not sure what is the issue. Did you try any of the drivers I listed or did you get 0x80300001 error installing W7 without 11.7.0.1013 or 11.7.4.1001 driver?

Also why did you mention your USB drive is read only? Why is it read only? I believe that this error can indicate issues with the storage driver or install media.

 

Usually I use Windows 7 USB/DVD download tool

http://www.microsoftstore.com/store/msusa/html/pbPage.Help_Win7_usbdvd_dwnTool

and I would just copy driver files onto the same USB pendrive.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

byh
Kilobyte Kid
byh
Posts: 5
Registered: ‎03-03-2014
0

Re: M500 SSD Not Recognized by Windows 7 Installation on Lenovo G450

[ Edited ]
in reply to bogdan

bogdan wrote:

I am not sure what is the issue. Did you try any of the drivers I listed or did you get 0x80300001 error installing W7 without 11.7.0.1013 or 11.7.4.1001 driver?

Also why did you mention your USB drive is read only? Why is it read only? I believe that this error can indicate issues with the storage driver or install media.

 

Usually I use Windows 7 USB/DVD download tool

http://www.microsoftstore.com/store/msusa/html/pbPage.Help_Win7_usbdvd_dwnTool

and I would just copy driver files onto the same USB pendrive.


1. I tried both set of drivers and got 0x80300001 popped up when i remove the USB pendrive.

 

2. If i proceeded normally, this error is displayed:

 

Setup was unable to create a new system partition or locate an existing system partition. See the Setup log files for more information.

 

3. I changed the USB setting to read only after a few failed attempt, as others have some success with it.

 

4. I used the Win 7 USB/DVD tool too.  I didnt keep the drivers on the installation USB pendrive because the drivers don't seemed to be picked up when i boot from the USB.I use a separate USB pendrive for the drivers.

 

5. When you copy the driver files onto the same USB, do you partition the USB?  

 

6. Will try to create another win 7 sp1 pendrive again and try it out. Thanks!!

JEDEC Jedi
bogdan
Posts: 1,551
Registered: ‎09-26-2012
1

Re: M500 SSD Not Recognized by Windows 7 Installation on Lenovo G450

[ Edited ]

To be honest I didn't have to do installation this particular way before, I would just try to copy driver files onto the same USB pendrive but you may be right it could be necessary to do with with second USB pendrive. I don't know.

Alternatively you could probably use DVD as a install media and USB pendrive for the drivers. I would avoid changing any default settings or making USB pendrives read-only.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Binary Boss
Chuckiechan
Posts: 13
Registered: ‎02-08-2014
0

Re: M500 SSD Not Recognized by Windows 7 Installation on Lenovo G450

[ Edited ]
in reply to bogdan

Deleted. I didn't notice how old this thread was! :smileyembarrassed:

Fatality Killer FX990 Board
AMD 8350 CPU
GTX 670 Video card
8 gigs Corsair DDR3 1333mz
M500 240G SSD
Antec TP3-650 Power Supply
byh
Kilobyte Kid
byh
Posts: 5
Registered: ‎03-03-2014
0

Re: M500 SSD Not Recognized by Windows 7 Installation on Lenovo G450

in reply to bogdan

I feel like an **bleep** now because the DVD install was so smooth, i didnt have to do anything but press accept.

 

All the wasted time... and the m500 is getting a big discount now...

 

Thanks bogdan!!

Our Latest Posts