M550 1TB not accessible after sanitize process.

Kilobyte Kid

M550 1TB not accessible after sanitize process.

I have used a M550 1TB SSD for a while and it has worked great with zero problems. I decided to upgrade to a different drive and sold the 1TB drive to a friend. Prior to sending the drive, I used Micron Storage Executive to do a PSID revert first, followed by a drive sanitize. The sanitization process seemed to work fine...it said processing for a good while but the process appeared to complete.

 

Now the drive is unaccessible. MSE nor Windows 10 see the drive.

 

Did I brick the drive? Is there anything I can do?

 

[EDIT] I just tried the power cycle method recommended by Crucial. The drive shows up in the BIOS, but is not visible in Windows or Micron Storage Executive.

1 Reply
JEDEC Jedi

Re: M550 1TB not accessible after sanitize process.

Drive sanitize shouldn't brick the drive. Both 'PSID Revert' and 'Sanitize Drive' (and ATA Secure Erase) leaves the drive in an uninitialized state. Did you check Windows 'Disk Management' is the drive visible there?

 

Instead of Micron Storage Executive try Crucial Storage Executive tool.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!