MX100 Corrupt Bios - How to reset to default bios?

Bit Baby

MX100 Corrupt Bios - How to reset to default bios?

All of a sudden my  mx100 - 500 GB (CT512MX100SSD1) stopped working. Bios can detect it with random ASCII characters instead of crucialmx100, I've checked the drive with Crucial Executive Tool and it seems like the driver does not recognize as crucial most of the values are missing and it's called unknown device on windows disk management tool. When I try to initialize disk on disk management it's also giving an error.


I've downloaded the only Bios File on the site but when I try to flash that with Executive Tools it says I've used the incorrect file, I tried both the zip file and the iso file inside zip.

I've also burned the image tool to USB drive and tried to flash it from bios but when I boot from USB drive it says remove media press continue. Then it says the system will reboot without doing anything on the drive.

Disk management and executive tool detect the size of the drive properly so I assume, this is just a matter of properly flashing the drive the default bios but I've unable to do it either using the executive tool or bootable Linux flasher.

I've 2 more years of warranty but I would like to keep drive if possible if I can fix the issue. I don't care about the files inside at this point.