MX300 SATA 3 capped at SATA 1 speed

Kilobyte Kid

MX300 SATA 3 capped at SATA 1 speed

Hi everyone. I Recently bought an SSD to insert in my Dell XPS 15 9550, together with the M2 disk.
So now i have:
1 M2 with PCIe (Windows 10 running on this disk).
1 SSD Crucial MX300 525 GB with SATA 3.

After i inserted it, I upgraded the firmware with the utility provided by Crucial (Crucial Storage Executive) and i made some speed tests: the result is that the speed of my ssd is SATA 1, 125 MB/s.
This is quite strange, as the motherboard has "Mobile Intel HM170 Express Chipset" and "Intel CM236", both provide SATA 3 interfaces. 

The Driver Controller is: intel(r) 100 series/c230.
I have the cable XDYGX provided by Dell to link my ssd to the motherboard.
All my drivers are up to date and also the firmware of my ssd.
HWinfo says that my motherboard provides SATA 2 / SATA 3 speed.

I tried to boot from a Linux Live from USB, same connection speed.
I tried to downgrade the BIOS, same connection speed.


What do you suggest?
Thank you

2 Replies
Bit Baby

Re: MX300 SATA 3 capped at SATA 1 speed

I have the same problem. Does anybody have a suggestion? Did you find a solution over the time?

Kilobyte Kid

Re: MX300 SATA 3 capped at SATA 1 speed

yes i fixed the problem: i called Dell and they came to change my SATA cable with a new one.
The 2 cables were identical, even the ID cable (XDYGX).
The difference was in the SATA interface: the first was SATA 1 and the other one was SATA 3.
But neither me nor the technician were able to discover the problem. It's not a cable problem, because in that case, my PC weren't able to view the SSD. 
You should definitely call Dell, if you have an XPS, and ask to change the cable.