SSD LED Indicating Disk Activity Not Working

Binary Boss

SSD LED Indicating Disk Activity Not Working

Hello,

 

I have a Crucial 128 GB SSD installed on a new build running Windows 7.  My system has two front panel LED indicator lights, one for power on and one for hard drive activity.  The light for power on works.  The one for drive activity does not.  That is, it doesn't flash (blink) when the SSD is accessed.  I have the connector for that light connected to the proper header on the motherboard.

 

My question is this:  is this condition (LED not indicating disk activity) proper for this Crucial SSD?

 

Fred

 

 

7 Replies
JEDEC Jedi

Re: SSD LED Indicating Disk Activity Not Working

[ Edited ]

My drive light works.  From a quick google it appears that on some motherboards it depends on the sata port you plug it into.  Guess that explains why my manual says you should only use port 0 or 1 for main hard disks. Smiley Happy

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Binary Boss

Re: SSD LED Indicating Disk Activity Not Working

targetbsp,

 

Well, my motherboard only has two SATA ports, 0 & 1.  I have the Crucial connected to 0 and the optical drive connected to 1.  I guess it's fair to say that I don't understand what's happening with this situation.

 

I wonder whether reversing polarity would make a difference.  There is no indication (with the case) of which one of the two wires (from the light to the header) for the LED is positive and which is negative.  One wire is white and the other some other color, don't remember what (could be orange).  I remember that I connected the white wire to the positive side of the header.  I was very careful when reading the motherboard manual to make sure I followed all directions correctly.

 

I'm too lazy to take the time to open the case to find out for certain what color the other wire is.  For lights, I've not noticed that polarity makes a difference.  They seem to work regardless of the polarity.  Anyone have any insight into this condition?

 

Thanks,

 

Fred

JEDEC Jedi

Re: SSD LED Indicating Disk Activity Not Working

As you only have 2 sata ports - I take it you have IDE ports?  From what i've read some boards can only work the light for one connection type or the other.  Other boards won't light up for sata full stop.  You're probably best off asking on your motherboard forum.

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Binary Boss

Re: SSD LED Indicating Disk Activity Not Working

targetbsp,

 

Yeah, i have one IDE header (mini-ITX board), but I'm not using it.  I only have one hard drive (Crucial) and one optical drive.  That's all I ever need.  I suppose you are correct in that I should ask this question on another forum.  I only posted here in the first place because I wanted to know what experience others are having with this LED using the Crucial SSD.

 

Thanks for responding,

 

Fred

Bit Baby

Re: SSD LED Indicating Disk Activity Not Working

Yeah!........Fred,

I'm having the same problem and I was wondering if the LED is actually supposed to work with an SSD?  I'm guessing that maybe because there are no moving parts in an SSD then the LED doesn't sense it working or something like this.  However, a few places I've looked online said it should flash with either an HDD or SSD.  So don't know.  Guess I will go and check the wiring and maybe reverse the connector to see if that changes anything.

Bit Baby

Re: SSD LED Indicating Disk Activity Not Working

Hey, Fred,

Yeah!  I'm having the same problem on a brand new build.  I was wondering whether or not an SSD will actually trigger the LED if there are no moving parts in the drive.  However, I've read a few places online that have said it doesn't matter if it's an SSD or HDD the LED should still work.  So.....maybe I have some connections hooked up wrong on the MB.  That's my next step........to check that out.

JEDEC Jedi

Re: SSD LED Indicating Disk Activity Not Working

Yes, an SSD will cause the drive light to flash when it's in use.

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?