Solution: C300 Disk Freeze-ups in Windows 7 solved for me

Bit Baby

Re: Solution: C300 Disk Freeze-ups in Windows 7 solved for me

If you discablled the HIPM and DIPM, the power management function is gone. In a drive, HIPM and DIPM are set enable as defauly. we cannot expect customer to disable them and use the drive. can you reply my question? I cannot post from the original page.

Thanks,

*removed personal information*

JEDEC Jedi

Re: Solution: C300 Disk Freeze-ups in Windows 7 solved for me


ggao wrote:

can you reply my question?


Sorry... what is your question?

 

Note that this is a four year old thread that applies to a drive model that's been replaced about four times over. I don't think many people would be looking to do this these days. Smiley Happy

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Highlighted
Bit Baby

Re: Solution: C300 Disk Freeze-ups in Windows 7 solved for me

First of all, thank you!!! I saw the light by reading your post, and the problem was solved by following your instructions.

 

I can confirm that this problem also exists in other SSD hard drives, like the Samsung SSD 850 EVO mSATA. I have a Dell M4800

 

I have been looking to solve this problem for two months. I had discovered that the problem was less frequent when the power supply was plugged. When the computer was operating only from battery, freezing occured almost instantly after loading the windows welcome message.

 

There are some people saying that a solution is disabling AHCI from BIOS, working only under ATA compatibility mode. And it is true that this works, because ATA has no Low power management features. But the right thing to do is to disable the LPM management from Intel Rapid Storage.

 

There are two options to do this:

- The first one is to alter the windows registry, as explained in this post.

- The second is to disable it from the Intel Rapid Storage control panel (tab "Performance")

To be sure that this works, just do both!!

 

And if you are worried about disabling LPM, just don't!! This is only useful for mechanical hard drives. SSD drives have a very reduced power consumption and do not really get any benefit from LPM.