Showing results for 
Search instead for 
Do you mean 
Reply
SODIMM Sherpa
Dionysos
Posts: 52
Registered: ‎02-06-2012
0

low 4K-64Thrd with AS SSD

[ Edited ]

Hello,

 

I have a m4 128 GB since 06/11. It was built into a SATA II system, and gave me perfect results for that "old" plattform. After I tested the SSD and everything was okay, I encrypted the whole drive with Bitlocker. I didn't feel any performance loss, everything was as fast as before. And Bitlocker supports TRIM.

 

A few days ago i built a new system:

Z68

i5-2500K @ 4.2 GHz

8 GB DDR3-1333

Windows 7 x64 NOT encrypted

 

I took the m4 out of the SATA II system, and installed Windows 7 on it in EFI-Mode. Then I installed all the programs i need, and run AS SSD to make sure everything is okay, before I encrypt my system again. The results were worse than on my SATA II system! Well, seq. read was better, but 4K-64K are too low.

 

Some Screenshots:

 as-ssd-bench M4-CT128M4SSD2 05.02.2012 13-10-10.png

 

with Prime95 @ 1 core:

as-ssd-bench M4-CT128M4SSD2 05.02.2012 13-12-39.png 

 

I filled the drive to 95%, deleted the files and left the system idle for a while. Didn't help.

I did a backup, secure erased the drive, restored the Backup. Didn't help:

as-ssd-bench M4-CT128M4SSD2 06.02.2012 11-46-35.png 

 

That's what CrystalDiskInfo reads:

Unbenannt.png

 

I don't get better results in safe mode. The only difference to the system before is that I installed Windows in EFI mode... but that can't be the reason, can it? Any suggestions?

 

Kind regards, Dionysos 

SODIMM Sherpa
Dionysos
Posts: 52
Registered: ‎02-06-2012
0

Re: low 4K-64K with AS SSD

in reply to Dionysos

It seems to be the EFI mode...

 

I just installed Windows without EFI, chipset drivers and iaStor.

AS SSD test results:

 

I wonder if there are any differences regarding real world performance. Not sure, if I should restore the EFI backup or go through the installation process of all the updates and programs again...

JEDEC Jedi
targetbsp
Posts: 7,604
Registered: ‎08-27-2009
0

Re: low 4K-64K with AS SSD

in reply to Dionysos

Low 4k-64 results seem to be typiclaly caused by power saving features.  It stands to reason that a modern replacement for BIOS such as EFI would be designed to make your computer power efficient by default I would guess?  Whether you can disable some of these settings I don't know.  I've never used an EFI system!

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

SODIMM Sherpa
Dionysos
Posts: 52
Registered: ‎02-06-2012
0

Re: low 4K-64K with AS SSD

[ Edited ]
in reply to targetbsp

I was wrong. Of course it has nothing to do with the EFI-Mode.

 

 

Yesterday I lost all my data. How did it happen?

Z68 Extreme3 Gen3 (BIOS 1.30)

i5-2500K @ 4,2 GHz

8 GB DDR3-1333

1x Crucial m4 128 GB

1x Samsung HD103UJ 1 TB

1x Samsung HD204UI 2 TB

all encrypted with Bitlocker (I have all keys)

 

I did a system image recovery.

When I rebooted, the 2 partitions on my 2 TB HDD were RAW.

I had the restored backup from 04.02.2012 on the m4.

The 1 TB HDD was still encrypted, and  I was able to access it with the key.

I tried a few things to get back my data from the 2 TB HDD (manage-bde or repair-bde didnt work).

Then I unplugged 2 TB HDD, booted, and plugged in the 2 TB HDD again. That obviously killed my 1 TB HDD! The 1 TB HDD isnt recognized any more and sound very bad... it's broken.

My external HDD, where I had at least the most important data... you can guess what happened to it (on another system though).

Now I am desperate...

 

Whatever, I had to install Windows. And this time I wanted to find out, what the reason for my low AS SSD Benchmark score is.

So I unplugged both HDDs, secure erased the m4, installed Windows 7 x64 on it.

Test with AS SSD after every driver or program installation.

 

But no matter if "normal" or EFI install mode, all energy saving features switched off in BIOS, Prime95 on 1 core, msahci or iaStor: I don't get a better score! Just once i had ~800 points on a fresh install (Windows 7 SP1 only, no extra driver), but when i repeated the test I had the same poor benchmark score as always (500-540 points). Same as in post #1. I also tried the tool targetbsp created (ssdtool).

 

The system is really fast, I don' feel the low benchmark score... but I know it.

I am double desperate.

Is it my mainboard? Maybe something wrong with SATA-Ports?

 

Help! Every idea is welcome!

Bank and Slot Hot Shot
lsdmeasasp
Posts: 4,404
Registered: ‎09-16-2009
0

Re: low 4K-64K with AS SSD

in reply to Dionysos

Are you encrypting the SSD?  You mentioned Bitlocker, and this is encryption, but you didn't say if you are using this across the entire SSD or not.  

 

If you are encrypting the windows partition, this would be the cause of slow scores, encryption slows down performance

SODIMM Sherpa
Dionysos
Posts: 52
Registered: ‎02-06-2012
0

Re: low 4K-64K with AS SSD

in reply to lsdmeasasp

That would be too easy, right? :smileywink:

 

I tested everything as i wrote... without encryption.

I used Bitlocker before, but for testing:

- secure erase

- install Windows x64 in EFI and in "normal" mode, NO encryption

- tried different ahci-drivers (msahci, iaStor)

- tried with a few SATA cables

- tried different drivers, tried without extra drivers

- tried the ssdtool from this forum

- switched off all energy saving features

- tried with prime95 on 1 core

 

I really tried like a 100 different driver and software configurations. I did a secure erases between os-installs. I left the computer idle.

 

I am really out of ideas.

To me it looks like either the mainboard or the SSD is the problem.

 

:smileysad:

Bank and Slot Hot Shot
lsdmeasasp
Posts: 4,404
Registered: ‎09-16-2009
0

Re: low 4K-64K with AS SSD

[ Edited ]
in reply to Dionysos

Do you have the SSD connected to the first Intel SATA Port, usually labeled SATA3_0 or SATA3_1?  Use the zero port if you have 0 and 1.

 

Also test with Native enabled and disabled in your BIOS, if you have that option directly under the IDE/AHCI/RAID setting.

 

What Intel Option ROM is in use, do you know?   You can check on the RAID screen, or within the option ROM itself if you have RAID enabled.  You can remove all hard drives and enable RAID and reboot and then you'll see the option ROM information during post, or you can enter the ROM itself by pressing Control + I during bootup (Normally that's the hotkey, you may need to confirm in your manual).


If it's an old version I can probably update it for you, but you'd have to be willing to flash an untested BIOS.   Don't worry, I wouldn't give you a modified BIOS if I wasn't comfortable that it would be OK.  Often if it's a very old version that may be the cause of slow speeds, so updating this often helps.   If it's 8.x that's really old, if it's 9.x that's kind of old (9.6 is the oldest suggest ROM for use with SSD's), most motherboards are now using 10.x or above RAID Option ROM's.   I have the latest 11 Alpha/Beta, or older 10/11 versions, so I could do any one you wanted.   Link me to your latest BIOS if you want me to have a look and see if I can modify your BIOS type.

 

I see they noted an update to the RAID ROM in yoru last BIOS update, I'm checking the version now and will let you know the current version, and if I can update it for you or not, if you want that is!


In addition to that, you could try right now a clean install in RAID mode instead of AHCI, that may be a little better for you anyway, that's how I always run SSD's.   And of course if you do that update to the latest RST after you get installed.  Any non RAID disk will just show up as a Non-Member in the RAID table, you do not have to have actual RAID arrays setup to use the RAID setting.

 

 

Bank and Slot Hot Shot
lsdmeasasp
Posts: 4,404
Registered: ‎09-16-2009
0

Re: low 4K-64K with AS SSD

[ Edited ]
in reply to lsdmeasasp

OK, I extracted the current one from BIOS 1.30 that they just updated and it is 10.8.0.1303, so it shouldn't be the source of any slow downs.   But I can still update this for you if you want, if so let me know!

 

I can update the ROM to11.0.0.1339, the matching drivers are 11.0.0.1032, and this is the latest Official update

http://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=20868

 

Or I can update it to 11.5.0.1111, which is working well for many too, all up to you if you want to try an updated one to see if that helps.

 

SODIMM Sherpa
Dionysos
Posts: 52
Registered: ‎02-06-2012
0

Re: low 4K-64K with AS SSD

in reply to lsdmeasasp

Thanks a lot, I really appreciate that. What a support! :smileyhappy:

 

But I know how to update the orom and I better stay with 10.8 for now.

 

I have one more m4 128GB in another computer. I will try it with that one on my Extreme3 Gen3 the day after tomorrow. I'd love to test right now, but the other computer is needed...

 

If the second m4 will perform as this one, I guess the mainboard is the cause.

 

I will let you know.

Cross fingers, that the mainboard is the cause. :smileywink:

 

 

SODIMM Sherpa
Dionysos
Posts: 52
Registered: ‎02-06-2012
0

Re: low 4K-64K with AS SSD

in reply to lsdmeasasp

Oh... didn't see your post before, sorry.

 

SSD is connected to 1st SATA port (SATA3_0).

I always use AHCI.

IDE doesn't support NCQ, so that should give me worse performance.

Installation in RAID mode? On a single SSD? I don't really understand why that's better and never heard about, but I will try.

 

Thanks for all your help!

 

Our Latest Posts