Dell Latitude 110l

Kilobyte Kid

Dell Latitude 110l

I have a dell latitude 110l wirth 256mb of memory. I have tried to upgrade the RAM 3 times. When additional RAM is inserted, the laptop will not boot. Remove the RAM and the laptop boots.


Tried twice with 1GB upgrade and again with 512mb. Same result.


Checked in the Bios and the existing memory is 333khz. This is what has been ordered. The RAM upgrade needs to be DDR1 ( I assume DDR and DDR1 are the same).


The laptop is running windows XP professional.


Any suggestions?

1 Reply
Community Manager

Re: Dell Latitude 110l

Hi soloski,


First of all I'm sorry to hear that you are having problems upgrading your memory.


I have had a look in to this system and it can support up to 1GB of memory in a single slot.  When installing new memory it can sometimes look like it's fully installed but it needs to be pressed in harder.  I would try the new memory again but making sure that it's installed correctly.  Sometimes older memory goes in quicker so it could be down to the memory not being installed correctly.


You said that you have ordered additional RAM, did you order it from Crucial?  If so can you confirm the part number of the memory you have ordered?  It will be printed on the label on the memory and look something like "CT12864X335.16FFY"


You can see all the memory we recommend for this system HERE.  Please let us know how it goes and if you need any further help we would be more than happy to help.

Crucial_Junket, Crucial Moderator, UK

How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?