System Not Recognizing RAM

Kilobyte Kid

System Not Recognizing RAM

Ok to start I do Have 64bit windows 7 and I did make sure the maximum memory box was not checked.


The Issue I'm having is my system is only showing 4gb of ram (3.99 usable)


But I have G.SKILL Pi Series 6GB (2GBx3) DDR3-1600 PC3-12800 (F3-12800CL8TU-6GBPI) RAM installed.


My mobo is an Asus P6X58D-E and has the triple channel support (of which there are 6 total but I have just the 3 filled)

I have to 2 Nvida Geforce 550 2gb cards installed, SLI linked.


I could be totally wrong here, but are they what my system is seeing and totally Ignoring my ram?


The manual says the 3 black channels are the main, and that's where the ram is installed, I tried putting them in the blue, just to see, but my monitor doesn't work when I do that, so no clue there....hope that didn't mess anything up. I put em back in the black channels and it booted back up fine to the way it was.


I pressed plenty hard till the white clips snapped into place and made sure they were even and firm. I haven't gotten in there with bright light and magnifying glass to make sure the mobo slots don't have any bent prongs yet...I was hoping it wouldn't come to that and there might be a non hardware solution.


Also I wasn't sure about putting them in one at a time to check them cause of the triple channel thing. I didn't know which side has the "first" channel.


Here is my system info...I can add the full report if I didn't put up what ya need.

System Information
Time of this report: 3/18/2014, 13:37:26
Machine name: ARCTURUS-PC
Operating System: Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130828-1532)
Language: English (Regional Setting: English)
System Manufacturer: System manufacturer
System Model: System Product Name
BIOS: BIOS Date: 11/16/10 18:07:45 Ver: 08.00.15
Processor: Intel(R) Core(TM) i7 CPU 960 @ 3.20GHz (8 CPUs), ~3.2GHz
Memory: 4096MB RAM
Available OS Memory: 4088MB RAM
Page File: 1512MB used, 6659MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 64bit Unicode


Drive: C:
Free Space: 40.2 GB
Total Space: 244.2 GB
File System: NTFS
Model: PLEXTOR PX-256M3 SCSI Disk Device
Drive: E:
Free Space: 202.3 GB
Total Space: 1430.8 GB
File System: NTFS
Model: ST1500DL003-9VT16L ATA Device
Drive: G:
Model: ATAPI iHAS124 B ATA Device
Driver: c:\windows\system32\drivers\cdrom.sys, 6.01.7601.17514 (English), 11/20/2010 20:23:47, 147456 bytes
Drive: D:
Model: DTSOFT Virtual CdRom Device
Driver: c:\windows\system32\drivers\cdrom.sys, 6.01.7601.17514 (English), 11/20/2010 20:23:47, 147456 bytes

4 Replies
Kilobyte Kid

Re: System Not Recognizing RAM

Also I was poking around and came across the Virtual memory setting for windows. It says the system is currently allocating 4087 MB but reccomds I set it at 6130 MB. 


Is this related? 


Should I change it?


Will that fix the problem?


Thanks again for any help you guys can offer!

Kilobyte Kid

Re: System Not Recognizing RAM

Correction and update. 


Firstly, I got the color of the Ram channels stwitched when I said everything. I was using the main channels to start, the BLUE, switched them into the secondary BLACK channels and the monitor wouldn't work. I switched them back to the BLUE main channels and it booted fine again, but still reads 4gb RAM. 


Secondly, I figured out which slot was the first channel, the blue one closest to the CPU. I went through each card one by and, and each reads 2GB when I boot up to windows. So as far as I can tell, all the cards are in working order, so the problem isn't there.

Kilobyte Kid

Re: System Not Recognizing RAM

Ok so I seem to have fixed my problem.


Before I took out the three RAM cards I had changed my virtual memory allocation to 4087-6103, from the default "system managed" setting it was on, that did not specify a page size. 


I rebooted my comp, with the 3 sticks in, but it still read only 4087.


Thats when I tried each of the three sticks, one by one, to make sure none were faulty and made my last post. 


So just out of curiosity I tried a single stick in each blue channel, one by one, to make sure each channel was picking the RAM. Each time I booted there was 2gb like one would expect. 


Defeated and confused what the problem was, I put my three sticks back in and booted up. Now mind you, I pressed REALLY good on em this time. I pressed really hard on them all like 5 times before but whatever, apparently that was the problem? Cause when I logged back in this time, I checked my RAM, and there it was, 6GB now, not 4.


So just to be sure, I looked at the virtual memory, and lo and behold, it was reading 6130, not 4087.


So I'm just curious, was the RAM not being picked up becuase of inadequate allocation, or was the additional virtual memory simply not there because I didn't have a card pressed in well enough?



Community Manager

Re: System Not Recognizing RAM

Hi Arcturus2013,


Thanks for contacting us today. Reading through the steps that you have taken with this RAM installation it sounds like it was most likely the allocation of the RAM. In some systems this allocation is required for all the ram to be "usable". I am glad that you were able to get everything resolved. Have a wonderful day. 


Best regards,

YogiH, Crucial Moderator, US

How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?