Crucial M4 128GB not seen by Windows 7 but still detected in the BIOS

SOLVED
Kilobyte Kid

Crucial M4 128GB not seen by Windows 7 but still detected in the BIOS

Hello everyone!

I have issue on my 128GB M4 Crucial SSD. I used it, then at night i switched off the computer. The next morning, i switched it on again and the SSD did no longer work. It is still detected by the BIOS but not by Windows 7 (device manager, disk manager, explorer). It was under the firmware 040H. I tried to make a firmware update under Windows, not detected (even when it was at working state it was not detected by the updater under Windows. That is why it remained stucked to the 040H version. So i download the bootable iso, burn it on a disk and i was able to update the firmware into 070H version. I restart the computer, but it still does not work. So i don't know what to do now. I really need your help.

Thanks in advance!IMG_20180306_171906.jpg

2 Replies
Highlighted
JEDEC Jedi

Re: Crucial M4 128GB not seen by Windows 7 but still detected in the BIOS

Try this: http://forum.crucial.com/t5/Crucial-SSDs/Why-did-my-SSD-quot-disappear-quot-from-my-system/ta-p/6521...

 

The M4 lacks the power loss protection of more modern drives and a crash or power loss and an ill timed moment can cause it issues that will be resolved by the above.

 

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: Crucial M4 128GB not seen by Windows 7 but still detected in the BIOS

Thanks a lot. I will try it.

Tags (1)