Crucial M4 64gb not being recognized in BIOS

Bit Baby

Crucial M4 64gb not being recognized in BIOS

It has been running perfectly since july 2011, but yesterday my computer froze and I had to force shutdown it. When I tried to turn it on again, the boot show an error asking to select any drive to boot. It doesn't recognize the SSD anymore.


I tried to plug it in other computers with no sucess, also I tried the two methods to reset it, the one from Crucial and the other one (only connect power cable and let it be 30 min in the bios screen, plug the data cable and restart with the reset button), but it does nothing.


The SSD is running the stock firmware, and I can't update it because the utility always gives a "no drive found" error.

I tried with Parted Magic but when it tries to restart the SSD unit keeps saying "Softreset failed (device not ready) and ends giving up.


I tried to plug it to another computer using an external 2.5" USB case and it recognizes the internal 350mb partition from windows 8 but the other partition is recognized as "RAW" and I have no access to all my files.



Should I RMA? What can I do? I have some important files in the disc that I need to recover Smiley Frustrated

1 Reply

Re: Crucial M4 64gb not being recognized in BIOS

Yes, so called power cycle is described here but I believe some users reported that sometimes it is necessary to repeat that process few times.

Can you see the drive in BIOS? If it would be listed in BIOS I would try switching SATA mode to IDE/Lagacy/Compatibile in BIOS and running Manual Boot File updater.


FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!