Feedback Thread: Firmware MU02 for MX100

Kilobyte Kid

Re: Feedback Thread: Firmware MU02 for MX100

Okay, it seems to be another error.


As far as i have understood there are 2? right now:


1.) BSOD issue


2.) The "freeze" issue


I received my MX100 a few days ago. Im not sure if Crucial has changed hardware inside, because the production cycle was at least about 1 year or so...sorry, i have no idea how to deal with 1.) issue..... said, i had to deal with issue no. 2, but for now with FW MU02 and a clean install it seem to be gone...system free of freezes is now ~52h....

1 x Crucial m4 / 128GB
2 x Crucial MX100 / 512 GB (MU02)
on Windows7x64-SP1 and Fedora 21

greetz Jeffrey
Bit Baby

Re: Feedback Thread: Firmware MU02 for MX100

zebul666 wrote:

Here is some file I wanted to share with you guys: is a bash script that extract the firmware from the crucial iso (you will need to be root).

You will get 2 files

MX100_MU02_128.bin which is the MU02 firmware for the MX100 128GB

MX100_MU02_LRG.bin which is the MU02 firmware for the MX100 with size greater than 128GB

md5sum are:

0a84d3662cf99a39c0adad01a6cec8a1 MX100_MU02_128.bin
a9214683464670a4266946efaf372499 MX100_MU02_LRG.bin


I guess you could use them with Storage Executive but use them at your own risk


Here is another bash script (you will need to be root) that I use to repackage crucial MX100_MU02_BOOTABLE_ALL_CAP.iso into an EFI bootable hybrid iso:  mx100.iso


This means you can use it to burn either a CDROM or into an USB key. Moreover you can boot in BIOS mode or EFI mode but not in secure mode.


That iso as only been tested in virtualbox so I can offer no warranty but it is just a repackage of crucial iso so the core files are identical.


I offer absoletly no warranty of any kind. Use these files at your own risk

Hey zebul,


thanks a lot for your adapted iso. I can confirm that the EFI hybrid iso works for me on my Macbook Pro (Early 2011). I had the same error '13' like everybody here on macbook with the burned iso from crucial. To prepare my usb stick I have used this guide:


# HOWTO: Make bootable USB stick from ISO on OSX 
# determine /dev/diskN name of USB stick (e.g. /dev/disk2) 
diskutil list 
# convert image.iso to image.dmg (hdiutil adds .dmg automatically) 
hdiutil convert -format UDRW -o image mx100.iso 
# unmount (don't eject!) usb stick 
diskutil unmountDisk /dev/disk2 
# don't f*** up device name in next step or your disk will be toast 
sudo dd if=image.dmg of=/dev/disk2 bs=10m 

The OS said that the USB stick is not mountable anymore. Don't be confused about that and shutdown Mac. Now start the Mac with 'alt' to show bootable devices. Than choose EFI Boot device and the update process should start. 


For me its finished successful finally.

Kilobyte Kid

Re: Feedback Thread: Firmware MU02 for MX100

I don't know much about Macs but I wonder if the conversion from ISO to DMG is really necessary.

Why not dd the ISO directly ? Will it not work ?
Bit Baby

Re: Feedback Thread: Firmware MU02 for MX100

Don't know if this step is necessary. I did it step by step based on the howto I found 


Re: Feedback Thread: Firmware MU02 for MX100

If the repacked iso from zebul666 works, then it is worth giving a nice kudo Smiley Happy


zebul666, could you post md5sum for your repacked iso in case someone would like to verify it?


FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Bit Baby

Re: Feedback Thread: Firmware MU02 for MX100

I have the 256GB model MX100. I tried to update using the iso on a USB drive prepared with the pendrivelinux installer. This is on an Asus M5A97 R2.0 motherboard (AMD chipset) with UEFI. CSM mode is enabled, as is Secure Boot.

When I booted off the USB drive using the non-UEFI option in the boot list, the SSD was correctly detected, but the installer gave a message about not being able to update the drive (unfortunately I didn't log the exact message).

I then re-prepared the USB installation disk using Rufus ( When preparing the USB drive, I used the option "MBR partition scheme for BIOS or UEFI computers" Again I booted off the USB drive and this time the installer ran and upgraded the firmware without any intervention. I did not change any settings in UEFI (Secure Boot was still enabled). For those having a problem getting the update to work, it might be worth trying Rufus.

Bit Baby

Re: Feedback Thread: Firmware MU02 for MX100

I have two mx100 512 GB drives that I updated using Storage Executive.  Both drives updated with no issues.  I'm hoping the problem that me and other users are experiencing has been fixed.  I clean installed Windows after installing the drives and experienced the problem where the computer would blue screen and the drive would no longer be visible until a few restarts/Power downs later.  Just a few days ago this happened on my boot drive.  I was unable to get Windows to recognize it until after running manual repairs.  The problem I'm having - Windows crash, drive not being recognized has happened on both drives at separate times.  It is not frequent, maybe once a month now, but extremely annoying.  Because both of my drives have experienced this problem, it makes me believe that whatever the issue, it's probably not due to a bad (failing) drive.    The motherboard I'm using is the Asrock Z97 Extreme 6, with updated bios and drivers.

Kilobyte Kid

Re: Feedback Thread: Firmware MU02 for MX100

Since the update MU02 (with crucial storage executive), my MX100 512GB gave me lots of BSOD in windows 8.1 x64. The Linx stability test gave me tons of errors quickly.

I tried to do a fresh install Windows 8.1 x64 => same bug.

I tried to put back my old M4 128GB and did a fresh install Windows 8.1 x64  => all works fine, no BSOD and linx stable.


What can i do?

crucial problème pas fiable
Kilobyte Kid

Re: Feedback Thread: Firmware MU02 for MX100

The MU02 firmware has done NOTHING for stability on these MX100 drives.


Crucial, please issue a recall. These drives are a disgrace to the Crucial brand and you need to make things right by your customers. The MX100 is just not fit for purpose.

Kilobyte Kid

Re: Feedback Thread: Firmware MU02 for MX100

For me the system will start to lag and then freeze. Shortly after that, it will BSOD and begin to reboot. During the reboot, if I access my BIOS, the boot drive (MX100) will not be detected. I power it down, remove the SATA cable. Plug it back in, turn it on, access BIOS to reset the boot order and back into business.


At this point, it's not fully reliable/stable. As seen with other users. The problem is that it is random and unpredictable when it will happen. For me it could happen in a few hours, weeks or months down the road.