M500 Issues with locking up (A TCG Command has returned an error)

JEDEC Jedi

Re: M500 Issues with locking up (A TCG Command has returned an error)

So it seems that I can share following workarounds that works on my systems in order to prevent silent TCG Opal activation on the drives during W8.x/W10 install:

 

- it works - create small partition at the end of the clean drive (with Parted Magic I have created 300 MB ntfs partition at the end of the empty drive) and then install Windows. This seems to be quite simple solution Smiley Happy

 

- it works - set ATA HDD password on the drive if your motherboard/laptop supports it and then install Windows

 

- it works - Shift+F10 at the begining of install (for example at this screen) and run following command (this is single line command)

Reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\EnhancedStorageDevices" /v TCGSecurityActivationDisabled /t REG_DWORD /d 1 /f

 

* You can also create small batch file (.bat extension) with the above command, place it on USB thumbdrive, Shift+F10 at the begining of install and run that .bat file.

 

- it doesn't work - Shift+F10 at the begining of install and run following command - that didn't work on my system

Reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\BitLocker" /v PreventDeviceEncryption /t REG_DWORD /d 1 /f

 

Edit:

There is one more thing that actually worked on my test system and I have found that out quite accidentally. Usually at the begining of Windows install I load Intel AHCI driver from USB drive. For that system I have loaded Intel RST 11.2.0.1006 and to my surprise Windows install haven't switched the drive to TCG Opal mode. However I am not sure if that would work with other/all versions of Intel AHCI driver. It may work because it seems that in general older Intel RST drivers does not provide OPAL support to volumes.

 

Note: Before applying any of the workarounds above the drive should be in ATA Security mode. So if the drive is in TCG Opal mode you should PSID revert it first.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Kilobyte Kid

Re: M500 Issues with locking up (A TCG Command has returned an error)

Thanks for doing this testing.

Kilobyte Kid

Re: M500 Issues with locking up (A TCG Command has returned an error)

Hi,

 

I have also been trying to figure out the way to solve this issue and I think I have figured it out, it has to do with switching the driver for the Marvell SATA 3 to AHCI. When you don't use the Marvell driver, the error occurrs, and when you put it back it is gone. In searching all the forums for this problem there  was no concrete answer for this issue, but after doing my own research, I realized that I had changed the drivers out, as many people do, and it also causes freezing and other issues, probably because the chip for the Marvell is wired into the motherboard. Also, they only time that this does happen is with Crucial SSD's so maybe there should be a fix for the firmware, if that is possible.

JEDEC Jedi

Re: M500 Issues with locking up (A TCG Command has returned an error)


noslack wrote:

it has to do with switching the driver for the Marvell SATA 3 to AHCI. When you don't use the Marvell driver, the error occurrs, and when you put it back it is gone.


The driver thing may be a good lead too, for example Intel RST AHCI drivers does not support eDrive (I am not sure about the latest revisions though). I have just updated my previous post.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Kilobyte Kid

Re: M500 Issues with locking up (A TCG Command has returned an error)

I hate to bring up this thread again but I recently had this issue with my MX100 where I would get this exact message. I'm going to attempt the partition method you mentioned. Do I have to create a partiton prior to the installation or can I create one on the screen where I pick a drive to install windows to?
JEDEC Jedi

Re: M500 Issues with locking up (A TCG Command has returned an error)

I am not sure, I have tested that trick the way it has been described. r0m30's idea was to put the small partition at the end of the drive in order to let the Windows installer create all its partitions the way it likes - that is small System Reserved Partition at the very begining of the drive and main/big OS partition. I have done that with free PartedMagic, you can download .iso file and create bootable USB thumbdrive with UNetbootin. It is usualy most convenient way for me Smiley Happy

 

Keep in mind that before you start W8 installation you should PSID revert the drive (it will wipe all data from your drive). Without that step the drive will still be in TCG Opal mode.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Kilobyte Kid

Re: M500 Issues with locking up (A TCG Command has returned an error)


bogdan wrote:

So it seems that I can share following workarounds that works on my systems in order to prevent silent TCG Opal activation on the drives during W8 install: .....


What about deactivating TPM in BIOS, does this also solve the problem?

JEDEC Jedi

Re: M500 Issues with locking up (A TCG Command has returned an error)

I am not sure but I think hardware TPM isn’t necessary for eDrive. Also knowing that Opal mode is silently activated by Windows installer my guess would be that deactivating TPM in BIOS wouldn't work as a workaround. But you can try that if you want Smiley Happy

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Kilobyte Kid

Re: M500 Issues with locking up (A TCG Command has returned an error)

I just wanted to say thanks for the work you've put into this issue. I have a M550 and I went from Windows 7 to Windows 10 Insider and then 10 Pro this week and for a while I've been having random crashes 3-5 times a week followed by restarts that become unresponsive after the lock screen, even after a fresh install of the final build. I used the reg ad method on clean install after a psid revert, and I've had substantially less issues and unexplained event log entries today compared to the last clean install I did.

JEDEC Jedi

Re: M500 Issues with locking up (A TCG Command has returned an error)


alanm26 wrote:

I went from Windows 7 to Windows 10 Insider and then 10 Pro this week [...] I used the reg ad method on clean install after a psid revert


Thanks for this information! I was just wondering if this registry modification works on Windows 10 Smiley Happy

 

 

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!