M500 SSD acting very strange.

Kilobyte Kid

M500 SSD acting very strange.

I'm fairly new to SSD's so I have no idea of the warning signs of a drive failing, but here is whats happening.

 

A few weeks ago windows popped up saying the recycle bin on my H: drive is currupted and if i wanted to empty it. I clicked yes and nothing happened for quite awhile before nothing at all happened lol... I tried to access the drive from explorer and it would not open, it just kept hanging up explorer (seems like a pre determinied timeout cycle). I looked into how to fix it and did the process, but it never worked properly.

 

I had an old install of windows on that drive as I was using it as a boot drive, so I just formated it hoping it would solve whatever was happening. Well it didn't fix it and now it seems like randomly it will let me access the drive ( I managed to copy a game back to the drive) but the majority of the time you can open the drive but if you try to go any further it hangs again.

 

Now when I restart my PC (normally takes about 15 seconds) it takes anywhere from 10-30m to cycle, same thing with shutting down. Anything that wants to access that drive like CMD prompts etc. again just hang and wont do anything.

 

Other then Windows 10 updates I havent changed any hardware or drives, so i'm not really sure whats going on.

6 Replies
Highlighted
JEDEC Jedi

Re: M500 SSD acting very strange.

Would you be able to read out and post SMART data of the drive? For example you could use CrystalDiskInfo, use 'Edit > Copy' option, just please remove drive's serial number. 

Also you can try to reseat the drive to check if that is some kind of a connection issue.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Kilobyte Kid

Re: M500 SSD acting very strange.

I would suggest running the mx500 without the other hdd. I don't know your system, but I just started a thread about my system hanging after windows 10 install on a mx500. These drives are VERY new and are indesperate need of new firmware. I would suggest reinstalling windows one more time with just the mx500 and make sure your bios sata mode is set to ahci.

JEDEC Jedi

Re: M500 SSD acting very strange.


siliconrage wrote:

These drives are VERY new and are indesperate need of new firmware. 


The M500 he is talking about is actually an old drive.  The MX500 is new. Smiley Happy

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: M500 SSD acting very strange.

The download link doesn't seem to be working right now, but i'll try again tomorrow.

 

I've just been using the Storage Executive software, this is what it displays if it makes sense lol

 

ID Flag Value Worst Raw Data

    1 50 100 100 124

    5 50 100 100 32768

    9 50 100 100 23130

  12 50 100 100 2122

170 50 100 100 18

171 50 100 100  0

172 50 100 100 0

173 50   88   88 363

174 50 100 100 934

181 34 100 100 7692292327077

183 50 100 100 0

184 50 100 100 0

187 50 100 100 0

188 50 100 100 6758

194 34   73   24 330706780187

195 58 100 100 4294967295

196 50 100 100 18

197 50 100 100 0

198 48 100 100 0

199 50 100 100 0

202 49   88   88 12

206 14 100 100 0

 

Again I have to reboot to get it to access the drive even on a basic level, It will see the drive, it juts can't do anything with it.

JEDEC Jedi

Re: M500 SSD acting very strange.

It seems the download site is down, I hope this is a temporary issue. If you wish you can try this link.

 

Here is the SMART attribute reference and it looks like there are some errors recorded, raw read error rate, reallocated sectors, some weird command timeout errors. There are many unexpected power losses too - are you sure the drive is connected properly? Did you try to reseat it?

Other than that you can check for newer firmware for your drive but it may be failing anyway, I am afraid Smiley Sad

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

JEDEC Jedi

Re: M500 SSD acting very strange.

 

Those SMART attributes are odd.   Definitely check & reseat your cables at both ends while also checking to make sure the contacts are clean & free of dirt and corrosion.  Make sure to check the contacts on the SSD as well.

 

In addition to making sure the SSD has the latest firmware installed, you should also check to make sure your computer's BIOS/UEFI firmware is also up to date.

 

More advanced options would be to stress test the SSD in the original computer and then placing it in another computer or connecting it externally for more stress tests (especially writing) while monitoring the SMART Attributes for changes.  This may tell you if the computer or SSD is at fault.

 

Another advanced option would be to perform an ATA Secure Erase on the SSD which basically resets & erases the SSD.  I've found this can sometimes resolve odd SSD issues, but this requires the use of Linux and I'm not sure there is any automated options which would be simple for you to use.