PSID Revert tool alpha release

Kilobyte Kid

Re: PSID Revert tool alpha release


Now the hdparm Screen

Kilobyte Kid

Re: PSID Revert tool alpha release

I have no Idea shat is wrong with your drive.  It's responding to ATA commands and OPAL commands but for some reason you cant write to it, strange.


About the only thing I can think of to try is switching it to another port and/or cable, I doubt it will help though.


You need someone smarter than me to bring this drive back from the dead, sorry but it's time to contact Crucial support.

Kilobyte Kid

Re: PSID Revert tool alpha release

Thanks for your Help!

I testet it in two PCs, so may be its a Hardware Problem.

Kilobyte Kid

Re: PSID Revert tool alpha release

Hi there.  Thanks for your response.


I checked with Toshiba on this drive regarding incorrect Opal 2 implementation, and here is their response. It appears that Toshiba would be willing to check it, too. There seems to be no updated drive firmware at the present.


Any chance the psid revert program could be changed to support Toshiba drives, or tell me how to do what is needed?




The session data (tokens) returned from the drive differs from that of Seagate and other SED drives.

After the EOD (End of Data) and EL (End List) tokens most suppliers have 0x00, we use 0xFF.  In this case

the 0xFF is an MT (Empty Atom) token which is perfectly legal and per the TCG Core Spec shall be ignored by the host.




 Empty Atom.png



If you can ask the programmer of that utility to ignore the Empty Atom token when seen in the response data from the drive, it is believed that the issue will be resolved with Toshiba drives.


If there is a way to get a copy of the revised utility (or at least notification of its revision number) we can download it and confirm in our own labs too.


Please let me know what feedback you get.  Thanks!





Kilobyte Kid

Re: PSID Revert tool alpha release

Well that's an interesting take on the spec,  We could argue over interpretations forever:

But lets not......


Look for a toshiba test exec @ later today/tomorrow


Here's the section I was referring to from pages 47 and 48 of the core spec. Pad
The pad field ensures that the boundaries between subpackets (and therefore packets) are aligned to 4-byte boundaries. The number of pad bytes SHALL be (-Subpacket.Length modulo 4). This field SHALL be zeroes.


Begin Informative Content The receiver of a Subpacket is able to unambiguously determine how many bytes of real data there are by examining the Length field in the Subpacket header. Note that the standard C library does not handle the modulo operation with negative numbers properly. End Informative Content


If the x'ff' fields were before the method status field then yes the tokens would be legal but I dont believe that the pad characters are atoms.

Kilobyte Kid

Re: PSID Revert tool alpha release



I have Micron realSSD C400 SED (MTFDDAK256MAM-1K12, firmware 04TH) drive which is locked and I forgot the password since it was not in use for some time.

I have contacted crucial support and they give me link to this thread. I have tried part magic and this tool but without sucess so far.


Parted magic got reckognized SSD (not frozen) but gets error when try to sanitize disk (both secure and enhanced). It shows following tags for the drive....enhanced security, not frozen, security MAX


when using msed it lists the drive but says NO as this drive is not opal2 compatible (but it supports opal1). I have used version beta0.11 and it should work with opal 1 drives too???


Does anyone managed to remove password (or to reset it) to unlock this drive. There are no data on it, so I would want to use it on another computer.


Also there is no PSID on sticker...they start to put it on the newer drives (m500 and so on), so could it be done without it. I hope this drive can be put in function somehow.


one more note...I tried this on systems with and without TPM module, systems with TPM asks for disk password at boot, those without do not but in both cases disk is locked in system managament.


Thanks in advance


Here are screenshots from msed, hdderase and sticker on the SSD





Kilobyte Kid

Re: PSID Revert tool alpha release



Yeah, I'm lovin how Crucial/Micron support points people here but refuses to discuss the tool with their customers,  free tech support anyone......


I can't see the screenshots Smiley Sad


I haven't heard from anyone else using msed with that drive but if it follows the spec it should work with msed.  How is the drive attached?  beta0.11 should see the drive as an OPAL 1.0 drive.


You say hdparm says not frozen, what about the other Security patamaters? enabled, locked ... etc.


Are you sure the PSID isn't on the label someplace?  It's hard to see on some dirves.


If you don't have a PSID then I'm afraid there isn't much that can be done with msed.


Re: PSID Revert tool alpha release

Crucial never released a version of that particular drive.  It was Micron only so it would have been for OEM (in which case support would be from your computer manufacturer) or enterprise (in which case I'm not entirely sure who provides your support!)


But yeah, this will be why they can't help you much. Smiley Sad

How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: PSID Revert tool alpha release

Well, now the first two screenshots are showing up, the third is still a red circle with a slash through it.


Your drive is locked in ATA security mode and msed will be of no use in unlocking it, sorry.

Kilobyte Kid

Re: PSID Revert tool alpha release

I saw the news on Tomshardware.


Looks like they finally release a psid reset tool?