Solved: disk freezes with M500 & AMD SATA Controller on Win7

Kilobyte Kid

Solved: disk freezes with M500 & AMD SATA Controller on Win7

I experienced disk freezes after cloning my original Win7 Home Premium HDD to a new 240GB M500 2.5" SSD.  I'm running a hp Pavilion g6 laptop, which is an AMD Phenom II quad core processor, so AMD motherboard and SATA controller.


Symptoms were an unresponsive system for about 30-40 seconds, happening every few minutes. Resource Monitor showed no disk activity.  The system would recover for a few minutes allowing normal operation, then would freeze again.


You can get to the Resource Monitor in Win 7 by right-clicking on the task bar, then:


Start Task Manager > 'Performance' tab > Resource Monitor > 'Disk' tab


There are a number of articles on this forum (e.g. C300 LPM Win7 and Is reg fix reqd for M4?) describing a possible cause being Link Power Management (LPM) and a fix involving disabling LPM in the registry, but these apply to older SSDs than the M500, so I didn't apply them.


In my case, I went back to AMD's drivers and support page and downloaded the recent AMD Catalyst 13.4 update (release notes).  This included an update to the SATA Controller driver (to driver version  You can check the driver version of your AMD SATA Controller by going to:


Control Panel > System & Security > Device Manager > IDE ATA/ATAPI controllers >AMD SATA Controller > 'Driver' tab


Not had a single disk freeze since applying the updates and rebooting.  Similarly, both sleep and hibernate functions are working fine.

Tags (5)
2 Replies

Re: Solved: disk freezes with M500 & AMD SATA Controller on Win7

Good tip!  Thanks for posting.

How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: Solved: disk freezes with M500 & AMD SATA Controller on Win7

I found the following solution with my two M500 240GB SSDs, so maybe your issue is related.  On the first one I did a clean install of Windows 8.1 Pro on an HP G60-230US laptop and everything worked perfectly.  I then cloned it to my 2nd M500 and it wouldn't even boot.  I cloned it again and although it appeared to work correctly at first, after running for about 2 minutes the disk usage would jump to 100% even though the task manager did not show any process with anywhere near that much activity.  The system stayed so bogged down the only thing I could do was a forced power off.  I then cloned it again but the results were the same.  Finally I simply wiped it and did a clean install, and as if by magic it worked perfectly like the first M500.  My 1st cloning was done with EaseUS TODO in the SSD mode, the 2nd cloning was done with EaseUS TODO in the non-SSD mode, and the 3rd cloning was done with Macrium Reflect.  I don't know why a cloned drive shouldn't work properly, but it obviously didn't in my case.  I believe that SSDs and cloning software probably have a long way to go to be completely reliable together. 

Tags (3)