Reply
Bit Baby
BobbyPeru
Posts: 1
Registered: ‎02-14-2014
0

960 GB SSD Just Totally Lost Format While Connected - Any Ideas?

[ Edited ]

Hey Everyone,

I was using a Crucial 960 GB drive in an OWC enclosure for about 3-4 months for audio work. Tonight the drive just started hanging, so I had to power down the computer. When I powered back up again, the drive is now 'unrecognizable' to the computer. It wont find the partition I had nor any of the data. I tried the drive on 2 different computers with 2 different enclosures with the same results.

 

1. Any ideas on how I can get this drive recognized?

 

2. Any ideas as to why this happened?

 

3. Any ideas as to how to get the data from the drive?

 

I'm using Mac's both with either Snow Leopard or Lion.

 

I didn't move the drive. It wasn't dropped or anything like that. Its in a separate room. No probs up until this point.I have 3-4 other firewire drives hooked up to the computer, none of the other drives failed.

 

Please help.

*removed personal information*

 

Shane 

 

Kilobyte Kid
izzyb
Posts: 3
Registered: ‎02-15-2014
0

Re: 960 GB SSD Just Totally Lost Format While Connected - Any Ideas?

[ Edited ]

I had a similar problem with an SSD drive which was being used externally with a Mac.

I also use OWC enclosures.

Macs are finicky if just one sector gets corrupted then puff goes the external drive, Mac's check hardware on boot so when you restarted the Mac the drive was ejected.

If you can gain access to a Windows Computer or you have Bootcamp installed and it is recognized there you can copy all your files on that SSD to Windows Computer and then reformat the drive to FAT32 while within Windows then restore your files to the SSD and it should then be all set to go with the Mac again. This worked for me. Hope this helps you.