Reply
Bit Baby
Warkois
Posts: 1
Registered: ‎07-28-2013
0

M4 SSD not recognized by MacBook Pro

The other day I did an OS update on my Mac. After rebooting it returned with a folder with a question mark. I took it to Apple and they ran a diagnostic on it and the M4 is not being detected. If I put in the original drive it works fine.

I attempted a firmware update hitting option on booting. The firmware starts but it quickly gives a message no drive detected. I have triple checked connections.

Is there a fix for this? Is it a faulty drive? Or did something get corrupted on the install?
Dual Channel Surfer
alex486
Posts: 317
Registered: ‎04-21-2012
0

Re: M4 SSD not recognized by MacBook Pro

[ Edited ]
in reply to Warkois

So it was working o.k. for a while and then it disappeared after reboot?

Or did it never work o.k. even once after the OS upgrade?

 

You could try following the instructions mentioned in these threads:

 

http://forum.crucial.com/t5/Solid-State-Drives-SSD-Knowledge/Why-did-my-SSD-disappear-from-my-system...

http://forum.crucial.com/t5/Solid-State-Drives-SSD/Crucial-M4-disappeared-after-restart/td-p/110880

 

The hot plug method mentioned in that second link might be a little more difficult if you don't have a desktop pc of some other machine where you can remove the SATA data connection without removing the power.

 

Kilobyte Kid
seelivemusic
Posts: 2
Registered: ‎08-07-2013
0

Re: M4 SSD not recognized by MacBook Pro

in reply to Warkois

What OSX are you running ?

 

Which M4 with what firmware version are you using ?

 

Don't suppose you have an enclosure or optibay you can use to look at whats going in with disk utility.

 

Nothing against the apple geniuses but they always look at me with complete confusion when I ask them anything beyond consumer level questions.

MBP 2.3 i5 16g w/ OSX 10.8.4
RAID 1: M4-CT256's w/ 040H firmware
VMware Fusion: W7, W8, 2008R2, & Ubuntu
20g-30g avail