Reply
Kilobyte Kid
astephens
Posts: 6
Registered: ‎05-25-2013
0
Accepted Solution

m500 BSOD on resume from hibernate

I got an m500 240 GB drive a couple of weeks ago to replace an HDD in my laptop, and did a clean install of Windows 8 on it. Now, the laptop will blue screen every time it resumes from hibernate. After looking at the memory dumps, the driver at fault tends to be storage system related (fastfat.sys, spaceport.sys). It never had hibernation issues with the HDD, and I would like to keep the power savings from hibernation.

 

I have not been able to find anything from searching online or on these forums similar to this issue. Some info on my system:

 

HP ENVY Sleekbook 6-1110us

AMD A-8 4555M

AMD SATA controller (PCI\VEN_1022&DEV_7804&SUBSYS_18DE103C&REV_00)

Crucial M500 240GB SDD (CT240M500SSD1)

JEDEC Jedi
targetbsp
Posts: 7,403
Registered: ‎08-27-2009
0

Re: m500 BSOD on resume from hibernate

in reply to astephens

You could try different versions of your sata controller driver.  Some cause my computer to crash on resume.  I have Intel though so there's no point in telling you what versions!  You'd have to try some.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Binary Boss
kevpan815
Posts: 31
Registered: ‎12-03-2012
0

Re: m500 BSOD on resume from hibernate

in reply to astephens
Same problem here after I replaced the Standard Generic Microsoft SATA Driver with the Driver that is actually designed for my AMD 700 Series Chipset/Mother Board! My 2010 PC dislikes my M500!
2.5 inch M4 Solid State Drive with 070H Firmware and 2.5 inch M500 Solid State Drive with MU02 Firmware.
Kilobyte Kid
astephens
Posts: 6
Registered: ‎05-25-2013
0

Re: m500 BSOD on resume from hibernate

in reply to astephens

Thank you both for your responses! When I get some time I will see what the sata driver version was on the old HDD. (I haven't repurposed it yet for situations like this). I'll be back with some results when ever I get around to working on it.

Kilobyte Kid
astephens
Posts: 6
Registered: ‎05-25-2013
0

Re: m500 BSOD on resume from hibernate

[ Edited ]
in reply to astephens

I just popped the old HDD in to check driver versions and such, and I have the same disk (MS: 6.2.9200.16384) and IDE ATA/ATAPI controller (AMD: 1.3.001.0043) on both installs, and I can confirm that hibernate is working  on the HDD.

 

Still can't say for sure though which component to blame. Anyone with a M500 and a non-AMD chipset experiencing issues with resuming from hibernate?

JEDEC Jedi
targetbsp
Posts: 7,403
Registered: ‎08-27-2009
0

Re: m500 BSOD on resume from hibernate

in reply to astephens

Have you tried different sata drivers?

 

I can resume fine using an M500.  But like I said, the sata driver choice matters for me on my C300.  Not actually tried different versions on the M500 but as the one I have works I'm taking an "if it ain't broke" approach!

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

JEDEC Jedi
targetbsp
Posts: 7,403
Registered: ‎08-27-2009
0

Re: m500 BSOD on resume from hibernate

in reply to targetbsp

This post here says hibernate works with the latest AMD sata drivers included in the Catalyst drivers: http://forum.crucial.com/t5/Solid-State-Drives-SSD/Solved-disk-freezes-with-M500-amp-AMD-SATA-Contro...

 

I presume they are downloadable seperately from AMD if you don't have ATI graphics for the Catalyst drivers.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Kilobyte Kid
astephens
Posts: 6
Registered: ‎05-25-2013
0

Re: m500 BSOD on resume from hibernate

in reply to targetbsp

Thanks for linking to that, but I tried those same drivers yesterday and didn't get any changes. Just to make sure, I did uninstall the current drivers and download and run the installer for the link jock provided, but it installed the same controller driver version (1.3.1.68). 

 

At this point I think I will just try to make the issue known to AMD, since a driver update seemed to fix other's problems and M500 owners on different SATA controllers aren't having issues.

Bit Baby
jrw71
Posts: 1
Registered: ‎06-04-2013
2

Re: m500 BSOD on resume from hibernate

in reply to astephens

Hi All, I have a similar problem with an m500 (120gb) in an old Del M4300 laptop. I've installed Win 8 Pro Ok and all seems ok except for KERNEL_DATA_INPAGE_ERROR BSODs on startup. Win 8 recovers and then I can reboot Ok after that. But, when I shut down the process repeats. It doesn't matter if it's a full shutdown, sleep or hibernate - same problem.

 

One thing I did do though while I was Googling and trying stuff out, was to turn "Fast startup" OFF (Control Panel > Hardware and Sound > Power Options then select "Choose what the power buttons do", then down the bottom of the next screen under "Shutdown settings", deselect "Turn on fast start-up". I did that and have not had a BSOD on boot up since, as long as I do a full shutdown. It still fails on hibernate or sleep though.

 

AFAIK, this option is similar to hibernate in that some information gets written to the disk to speed up the next boot. If you're experiencing hibernate issues, this probably won't solve them, but at least your PC might boot reliably from cold start. I can't tell the difference between a "fast start-up" a non optimised boot because I can't get it to boot from hibernation, but to be honest, Win 8 boots from my SSD in about 12 seconds anyway which is plenty fast for me, considering the age of my laptop!

 

Good luck all and apologies in advance for any typos!

Bit Baby
isthar
Posts: 4
Registered: ‎06-22-2013
0

Re: m500 BSOD on resume from hibernate

in reply to jrw71

Hello there. Had to register because I have to say "me too".

 

M500 SSD, Windows 8.

Catalyst latest drivers (Sata 1.3.1.68)

 

BSOD (KERNEL_DATA_INPAGE_ERROR)s every sleep/hibernate/all over the place, with various variants. I have just now disabled fast startup (since indeed if it is all about reading in data during the boot sequence that's any bit like hibernate, better get that out of the way).

 

Motherboard is a trusty old Asus M4A78T-E, AMD Phenom II X-3 720, 4GB of DDR3 (2x2GB Kingston hyperx something or other). I'm doing no overclocking, ram at 1333. video card is a new HD 7850 (was 4850).

 

I look forward to Crucial realising there's something wrong in their firmware; I find it a bit odd that the m500 has no firmware updates!

 

If crucial wants any information, I'd love to give it.