Highlighted
Bit Baby

Acer Aspire 3 won’t boot after ram upgrade

I used the scanner and picked out a ram that they said was compatible. But when I inserted the ram and tried booting up. Nothing but a black screen. Then I replaced it with the old ram and it worked just fine.

Laptop is Acer Aspire 3 A315-21-95KF max ram it can have is 12GB. 4GB that is not removable

New ram is 8Gb DDR4-2400 1.2 V CL17 part number CT8G4SFD824A.C16FADP

Original Ram is 2GB SOD DDR4-2400 CL 17

So not sure if the speed is wrong. Or wrong voltage or just a DOA stick.
2 Replies
Community Manager

Re: Acer Aspire 3 won’t boot after ram upgrade

@Jschwiderski I am sorry for the issues that you have experienced with your RAM. It does appear that you purchased the correct RAM for your system and that the part may be DOA. I would advise contacting us directly, so we can troubleshoot further and set up a return for you if needed. 

YogiH, Crucial Moderator, US


________________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Acer Aspire 3 won’t boot after ram upgrade

Hi there,

I've encountered the similar issue.

It pretty familiar to voltage shortage. As such: laptop turns on but the screen has no signs of life. Demounting of new RAM fixes the issue and laptop loads normally.

Is there any common workaround or detailed compatibility guide? Unfortunately I had no luck finding any.

 

Laptop is Acer Aspire 3 A315-21-6339. It comes with 4Gb solid RAM and 12Gb max cap and 1 slot available.

New ram is 8Gb DDR4-2133 1.2V CL15 CT8G4SFD8213.C16FHP  (fixed) 


Original Ram is 4GB SOD DDR4-2133

 

Thanks,