BX100 Not Visible in Windows, but is in BIOS

Kilobyte Kid

BX100 Not Visible in Windows, but is in BIOS

Hi...

 

I moved a 1TB BX100 from an older Dell laptop to the spare bay of a Dell 7520 laptop running Windows 10. The disk does not appear in Disk Management. It DOES show up in BIOS. It WILL show up in Windows if I put the disk an an external USB drive enclosure (and I did repartition and reformat it there). Any thoughts to get it to appear in Win10 Disk Management?

 

Thanks!

2 Replies
JEDEC Jedi

Re: BX100 Not Visible in Windows, but is in BIOS

Is the secondary bay possibly deactivated in the BIOS?   Or in Windows?

 

A quick way to determine if you have a hardware or software issue is to create a Knoppix Linux USB boot disk using Etcher and see if the BX100 can be seen by GSmartControl (Start --> System Tools).  If it does not show up in GSmartControl, then open a Terminal in Knoppix (black icon on the Taskbar near the Start menu) and issue the following command to look at the Knoppix boot log to see if you can see any messages related to the BX100:

 

sudo  dmesg  -t  |  grep  -iE  '^ata|^ahci|^raid|^scsi|sda|sdb|sdc'

 

I believe this should show any attempted communication with the BX100 if it is seen by Linux.  The previous command should display information for your main Windows drive as well as the Knoppix drive.  Use GSmartControl to learn the Linux identifier for your Windows drive & the Knoppix drive.  Remove those two drive identifiers from the previous command to reduce clutter or leave one so you can see what normal communication looks like.  For example, if your Windows drive is identified as "/dev/sda", then remove "sda|" from the command.   I'm assuming you only have the two installed drives and the Knoppix drive connected during this test.    You can also use this command:

 

sudo  dmesg  -t   |  less

to see the complete boot log.  Use the arrow keys to scroll and press 'q' to quit  and return back to the command prompt.

 

Make sure to download the latest version of Knoppix which should be v8.2.x IIRC.

Kilobyte Kid

Re: BX100 Not Visible in Windows, but is in BIOS

Thanks for the reply, I'll give that a shot.