Cannot Clone Bootable APFS drive with Mojave 14.1 using SSD MX500

Bit Baby

Cannot Clone Bootable APFS drive with Mojave 14.1 using SSD MX500

Hi all, 


I have recently purchased a Crucial SSD MX500 for my Mid 2012 Macbook Pro. I followed the Installation Instructions for Mac, and received an error when Restoring my SSD to Clone it. I formatted my SSD as a Mac OS Extended Journaled with a GUID Partition Table prior. I have also tried formatting it prior to restore as an APFS with a GUID Partition Table.


The error I see states "APFS inverter failed to invert the volume - Input/output error / The operation couldn't be completed. (OSStatus error 5.)


Therefore, I erased the drive again (Mac OS Extended Journaled, GUID Partition Table), booted into internet recovery mode, installed Mojave 14.1, booted up from the SSD and used Migration Assistant to transfer my data. All of this was done with my SSD connected externally via a SATA-USB cable. 


Upon installing the SSD, I see that Flashing Question Mark Folder (can't find system software). However, when externally connected, I have no problem booting up from the SSD when using option to select my start up disk. 


I have tried to do a lot of troubleshooting with regard to the APFS format required by Mojave, and have been unable to get my SSD bootable on it's own. Any help would be greatly appreciated. 



4 Replies

Re: Cannot Clone Bootable APFS drive with Mojave 14.1 using SSD MX500

Is your MBPro (mid-2012) a 13" model?  If so, you may need to replace the hard drive cable since they had a high rate of failure, but before that try the following:



Can you see the bootable SSD when installed internally and option booting?


Is the SSD using APFS now or HFS+?  Please double check as the installer may have converted it.


When option booting your SSD externally, is the internal drive bay empty?  If not, then remove the hard drive and try option booting the SSD externally again to make sure it is not using the original drive.


Try performing an SMC reset and a PRAM reset (hold PRAM reset for a full minute or about 3 chimes).


FYI, I think installing & migrating was your best option, but for those that want to clone an APFS volume, then I would recommend using Carbon Copy Cloner to do so.

Bit Baby

Re: Cannot Clone Bootable APFS drive with Mojave 14.1 using SSD MX500

Hi HWTech, 


Thanks for your reply. My MBP is a 13", the cable was previously replaced after failure a few years ago. 


I do not see the SSD when booting from option internally, but I do see it when entering into Internet Recovery Mode when it is internal. I ran First Aid on the volume, re-installed OS X, and still saw the flashing folder. No luck with SMC and PRAM reset. 


I removed the SSD internally, and connected it externally via SATA-USB (without replacing the HDD inside). I then had success when booting up from option with the SSD connected externally. 


The SSD is formatted as APFS. I was under the impression that Mojave will convert any HFS+ to APFS. 


My thoughts now are that it is either a a result of the APFS format, or the cable. However, the cable works fine when booting from my HDD. I was able to see that only 1 volume of the APFS format is mounted, and that is the SSD. I think two of the other three are for booting and recovery, but I cannot figure out how to mount them at the command line or otherwise. 


Any additional help would be greatly appreciated!





Re: Cannot Clone Bootable APFS drive with Mojave 14.1 using SSD MX500

Thanks for the detailed information.  Try reseating the hard drive cable to the Logic Board (unplug the power & battery first) just in case it got loose during the upgrade.  If it still won't work, then replace the cable again.   It is very hard to tell when this cable goes bad as they can fail differently every time and to greater or lesser degrees.  Since you can boot the SSD externally just fine without any internal drive this is the most likely issue.


One of the partitions is an EFI System partition which contains the actual bootloader link to the Recovery partition and/or the main partition (I'm not sure of the exact details on how it works with OSX).  The Recovery partition is used to repair the main partition or to allow FileVault.  You can mount & unmount them using the Terminal:


diskutil   list

Will show you all of the drives & partitions.   Your boot drive is usually disk0.   It will show disk1 as that is the CoreStorage volume created from the physical volume of disk0.   To mount & unmount the Recovery partition on disk0:

diskutil   mount   /dev/disk0s3

diskutil   unmount   /Volumes/Recovery\ HD

Don't mess with them unless you know what you are doing and are willing to risk making your computer non-bootable (especially the EFI System partition or your system won't boot).

Bit Baby

Re: Cannot Clone Bootable APFS drive with Mojave 14.1 using SSD MX500

Got a new cable and it booted right up. Thanks for the fix!