Crucial Drive Won't Stay Mounted as External Drive

Bit Baby

Crucial Drive Won't Stay Mounted as External Drive

I am using a Crucial P1 NVMe 2280 M.2 SSD as an external storage device installed in a Sabrent enclosure.  I installed the drive, plugged in via USB 3.0 to my iMac and initialized the drive.  Worked fine, appeared on the desktop and in the Finder window.  Copied about 50Gb of data onto it, then it sudden disappeared from the desktop and the copy procedure stopped.  I disconnected the drive and replugged it.  The drive appeared briefly, then unmounted again.  If I log out, disconnect and reconnect the drive, then log back, it works again for a while, then unmounts (10-15 minutes).


Any ideas on how to address this?

1 Reply

Re: Crucial Drive Won't Stay Mounted as External Drive

Most likely it is a power issue.  Perhaps the iMac isn't able to provide the necessary power to the SSD.  I would suggest using a powered USB 3 hub (with UASP support) to help buffer the connection and also provide the necessary power for the drive.   I actually have an iMac that will disable the USB port (requiring a restart to re-enable it) whenever I run tests on drives using a powered dock.  Problem doesn't happen when using a powered USB hub.


Try another USB cable.  I've had some USB 3 cables which I have to wiggle before the Mac recognizes the drive after which it works perfectly fine.


I worked with a couple of Sabrent SATA enclosures and never had a problem, but I wasn't too impressed with them.   Years ago I had another brand of USB enclosure which worked perfectly on a Windows/Linux system, but it would not work correctly on the Mac with OSX so I ended up returning it.  Ever since I either use StarTech, Plugable, or the OWC Mercury enclosures.   I've had some issues with StarTech USB3 products (at least on my troublesome Mini) so I've been migrating my stuff over to Plugable as I like how they provide real technical details about their products and they seem to work very well.