Crucial MX300 2TB - unable to detect in bios

Kilobyte Kid

Crucial MX300 2TB - unable to detect in bios

Recently brought one off amazon , replaced my old 240gb ssd.


I tried connecting it and i kept getting:


"Currect BIOS setting do not fully support the boot device"
"Go to advanced -> boot -> CSM parameters, and adjust the CSM settings to enable the boot device"


I tried different sata ports same thing , bios has never detected the drive at all. I even connected my old ssd and tried to connect the 2tb one aswell , nothing appeared in windows or bios.


I updated my bios to the latest version , nothing seems to make a difference.



*edit , just tested in another computer same results. It's one expensive paperweight.

1 Reply

Re: Crucial MX300 2TB - unable to detect in bios

You may want to verify the computer can actually handle a 2TB drive first.


Then assuming a SATA SSD, make sure AHCI is enabled on the SATA controller in the computer's BIOS.


Check for firmware updates for your computer to see if any address isssues or add support for large drives and/or SSDs.


Also go to Crucial's main page and select your computer to verify Crucial supports the SSD with your computer setup.


If all this fails, contact Crucial Support.  They will confirm the SSD is supported with your computer and verify which BIOS settings need to be set.  They may even determine the SSD is faulty.