Crucial MX500 M.2 not detected in BIOS anymore

Kilobyte Kid

Crucial MX500 M.2 not detected in BIOS anymore

Hello,

 

I have a desktop with just this ssd where it's installed Windows.
Windows got frozen so I had to push the reset button. After that, BIOS didn't recognize it anymore. Tried unplugged several times, toke off the pile of the motherboard (gigabyte B360M HD3), upgraded to the last firmware, tried using a case to connect it via SATA, tried also via USB, in other PC and nothing.
I did the power cycle several times without result.

 

My only hope is that my laptop has a M.2 connection too and the windows disk manager show it as DISK 0 but I can't perform any action. Also the SSD has a light green

 

Any other idea or it's definitely dead?? 

3 Replies
JEDEC Jedi

Re: Crucial MX500 M.2 not detected in BIOS anymore

See if you can use Crucial Storage Executive or GSmartControl (portable version available so no installation is necessary) to check the SMART Attributes on the drive and post them here if they show up.

 

The only other option I know which can provide information about what is happening is to use Linux.  Create a bootable Knoppix USB drive using Etcher.  Once you boot to the Knoppix desktop, open a terminal (the black icon on the left of the Taskbar) and type the following command which will open the system log and show new entries as they appear.  

sudo  dmesg  -tw  

After this command is given wait to make sure no new entries appear, then plug in your M.2 SSD using your USB adapter and see what information is posted.  Every new entry should be related to the external drive you just connected.  To terminate this command just press Ctrl + C.

 

Open another Terminal window and enter the following command to see if your M.2 drive shows up and what the system log reports as it trys to communicate with the SSD:

sudo  lsblk  -f

If you see your SSD in the list, then there is some positive communication going on.  We can try for data retrieval and a reset of the SSD.

 

If you cannot retrieve any SMART Attributes and Knoppix cannot successfully communicate with the SSD, then you will need to RMA it as I believe it should still be under warranty for five years.

Kilobyte Kid

Re: Crucial MX500 M.2 not detected in BIOS anymore

I've couldn't try it in my laptop (when I've started to run Knoppix said no config file found).

Tried in my old PC, seems like bad news..

Connected first via USB (all the useful info is below 4 line -> New seat seat0):
WhatsApp Image 2019-03-25 at 16.31.14 (3).jpeg

WhatsApp Image 2019-03-25 at 16.31.14 (2).jpeg

Tried with a sata case :

WhatsApp Image 2019-03-25 at 16.31.14.jpeg

 

I want to try it for last time connecting it via M.2 but I don't think it will change anything..

 

Thanks for your help

Highlighted
JEDEC Jedi

Re: Crucial MX500 M.2 not detected in BIOS anymore

This is a drive you need to RMA.   If the M.2 is installed internally, all of this failed communication which you see in the Knoppix logs may keep the system from booting to another drive.