Crucial MX500 SSD Failure

Highlighted
Kilobyte Kid

Crucial MX500 SSD Failure

My Win10 was installed on my SSD but last weekend my PC crashed with a blue screen error. I rebooted but my operating system failed to repair itself and I lacked a system restore point. So I reinstalled my USB version of Win10 to my ordinary HDD.

 

My SSD shows in the brower as a USB Drive which I cannot access or format. In device manager it shows under disk drives as a Generic STORAGE DEVICE USB Device. It has drivers, I have tried updating the drivers but it tells me the latest version is already installed.

 

Next I removed my HDD leaving the SSD as the only storage connected to my PC. I tried installed Win10 onto it then but it failed telling me the device had no drivers.

 

When I reconnect my HDD and boot back up the Crucial Storage Executive fails to detect the SSD. Acronis rejects my SSD as unregistered telling me I can get an unlimited version of Acronis from its website.

 

Please can anyone offer insights as to what is wrong with my SSD and how to fix it? The item is only 3 months old.

1 Reply
JEDEC Jedi

Re: Crucial MX500 SSD Failure

Was your SSD encrypted?  If so you will need to unlock it before being able to access it to recover files or to  repair or re-install Windows.   

 

There is an automatic Startup Repair option on the Windows installer that may help and there are a few commands that can be run from it (chkdsk and sfc \scannow) to try and repair the filesystem or system files.  It may even be possible to unlock an encrypted drive, but I'm not a Windows user so I'm not sure how you would do it.

 

Acronis is not able to identify your SSD as a Crucial device since the USB adapter is likely blocking this information or because it is encrypted.  You can either install the Crucial SSD internally or you need to use another USB adapter (the Crucial USB to SATA Adapter should work).   Unfortunately many USB adapters/enclosures/docks don't provide full functionality or even work with some hardware.