Didn't initialize, now can't do anything

Kilobyte Kid

Didn't initialize, now can't do anything

I tried to install an MX500 SSD into a 2008 unibody Macbook with a bootable flash drive of El Capitan. Extremely unfortunately, I missed the initializing step, and have since done a few Terminal workarounds to get it to have a GUID partition, a name, and to be recognized by the install drive, but the installation will not complete. It stalls in the final second - it never reboots, only eventually errors out.

 

I've also tried wiping the drive entirely, but that hasn't worked to bring back the Initializing diologue box. The drive remains unrecognizable in Disk Utility.

 

Is there a way to Initialize the drive at this point or is the SSD a total lost cause now?

5 Replies
Highlighted
Crucial Employee

Re: Didn't initialize, now can't do anything

To wipe the drive clean of whatever failed install or partial partition that's currently on the drive, I would suggest removing the SSD then simply erasing it through another Mac machine, or even better perform a diskpart clean on the SSD through a Windows computer.

https://forums.crucial.com/t5/Crucial-SSDs/Reset-Your-SSD-With-Windows-DiskPart/ta-p/176654

Once you have done that put the SSD back in the Macbook and get on older OSx installer, ideally the original for what you system shipped with (10.5.5 "Leopard"). Just because your system supports El Captain doesn't mean you can take a recovery media for that OS then do a fresh install. Often with older Mac systems you need to install a previous version of OSx then simply upgrade to the latest supported OSx. I had a problem trying to pu El-Capitan straight on my late 2009iMac, the installer would constantly error out. I had to get a Mountain Lion installer to put the OS on, then upgraded beyond that.





Crucial_Benny, Micron CPG Support, US


How do I know what memory to buy?
Shop for your region: US | UK | EU | France |
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
JEDEC Jedi

Re: Didn't initialize, now can't do anything

When you say the drive is unrecognizable in Disk Utility, do you mean you do not see the physical device in the left pane at all?  Try selecting the "View All Devices" from the drop down list just above the left panel in Disk Utility (if it exists with OSX 10.11).   Also, is your MacBook a "Late 2008" model as that is the earliest MacBook model supported by OSX 10.11.  Is your EFI & SMC firmware up to date on the laptop?  Use this link to check.  If it is not up to date, then you will need to install the updated firmware.  Check the OS requirements for the firmware.  Apple will only allow you to install the firmware with the OS listed so if you don't have a bootable drive with the correct version of OSX you won't be able to update the firmware.

 

If you don't want to remove the SSD, you can try booting to the OSX installer again.  As soon as the menubar appears (probably just after selecting your language), click on the Tools or Utilities menu and select "Disk Utility".  See if you can repartition the drive by selecting the drop down box and selecting "1 partition" and making sure the option for GUID is selected as well as HFS+ (journaled) and apply.

 

If this does not work, then open a Terminal instead of Disk Utility.  Make sure only the new SSD and the USB OSX installer are connected to the MacBook.  If you have any other storage devices connected, you might erase them with this option.

 

You need the identifier for your SSD so run the following command:

diskutil  list

If you only have the SSD and USB installer drives connected, then most likely the identifier for your internally installed SSD will be "disk0", but it could be "disk1", or it could be another depending on the number of connected devices and the type of volumes they contain.

 

The next step will erase a drive so be careful if other drives are connected.  This command will write about 1GB of zeros to the beginning of "diskX" so it destroys any previous partitioning information so the drive will appear blank.  For the following command replace the "X" in "diskX" with the identifier number found in the previous step (such as 0 or 1, etc).   

dd  if=/dev/zero   of=/dev/diskX  bs=1m  count=1000

Example assuming "disk0" is your MX500 SSD:    dd  if=/dev/zero  of=/dev/disk0  bs=1m  count=1000

 

After this command completes, launch Disk Utility again using the same instructions that I listed previously to partition & create a single volume.  Once Disk Utility creates a volume, quit it and continue with the installer.

 

A third option is putting the MacBook with the MX500 into Target Disk Mode and connect it to another computer.   You should be able to repartition the drive since it will appear as an external hard drive to the other system.

 

If none of this works and @Crucial_Benny's advice doesn't work, then provide a photo of the output of the "diskutil  list" command.  Also provide a photo of the Apple System Profiler  under "SATA".  It is possible you may have a loose or defective hard drive cable.  Edit the photo to remove the drive serial number if present.

 

Edit:  A fourth option is to leave the SSD installed and use Parted Magic to Secure Erase the SSD.   I believe others have used it with Apple hardware.  You should be able to make the USB using Etcher, but if it doesn't work you can burn a CD.

Kilobyte Kid

Re: Didn't initialize, now can't do anything

Thanks!

 

Yes, it's "late 2008." I picked El Capitan because "late 2008" is not compatible with anything newer, and nothing older seems to be available in the App Store. No, I can't see the SSD in DiskUtility at all in the left pane, either when I have it connected externally via SATA to USB cable or when it's internally installed. And no, I do not have the "View All Devices" option in OSX 10.11.

 

I have one working laptop - the Macbook I'm trying to install the SSD into - and one Chromebook, so no options for second computers or Windows. I've had the old HDD and the new SSD in and out about 40 times as I've tried everything I could find online to make this work. The only time the SSD shows up in Terminal with the "diskutil list" command is when it's installed internally; it doesn't show up when it's connected by USB. I have never had the option to choose my language any of the many times I've tried running the installer. The internal SATA cable is not faulty - it runs my HDD perfectly.

 

I'll try the firmware update.

Kilobyte Kid

Re: Didn't initialize, now can't do anything

Thanks! I'll try and hunt down a copy of Leopard.

JEDEC Jedi

Re: Didn't initialize, now can't do anything

Don't trust the GUI version of Disk Utility to always show everything.  Apple is removing features from the GUI apps with each new version of OSX so they are not as trust worthy when troubleshooting hardware.   Check Apple System Profiler to see if the SSD shows up as a physical device.

 

You may want to try connecting the SSD to your Chromebook to see if it can be seen or formated there.   I'm not sure I have access to a working Chromebook to assist you so you may have to search online for how to do that.

 

See if a friend or family member will let you connect the SSD to their computer and if it is using Windows, have them use Disk Management to check on the drive.  If you have an IT department at work see if they will check the drive out for you.

 

FYI, surprisingly when a SATA cable is bad it can still work with some devices just enough to appear Ok.   Since it also doesn't appear when using a USB adapter most likely either something happened to the partitioning/filesystem on the drive or maybe it just failed.  Best way to know is trying with another computer and/or OS.