Having trouble restoring to new SSD

Bit Baby

Having trouble restoring to new SSD

I am trying to replace the SATA hard drive in my MacBook Pro (early 2011) running High Sierra with a Crucual MX500 SSD. I followed the instructions to format the disk but when it came to restore data from my existing HD to the new SSD it would not work, saying that there was no logical partition defined. So I went through the formatting steps again and this time also created a second partition (only 10GB in size) as a test. However when i tried again to restore the existing HD to the new SSD it said that there was not enough room (despite the existing HD having only 480GB on it) and then when I tried to delete the small test partition, this operation failed with the error message: unrecognised file system (see below)


Screen Shot 2018-04-13 at 20.37.33.png


I am now utterly stuck. Can anyone help?

1 Reply

Re: Having trouble restoring to new SSD

FYI, your uploaded image has not been approved by a moderator so I cannot see it.


Install the MX500 in the laptop and make sure your original drive is not connected to the laptop.   Boot the laptop into Internet Recovery Mode (pressing & holding the following keys immediately after the startup chime:  Command + Option + Shift + R).    After selecting your language, I believe a menubar will appear at the top where you should see the Utilities menu.  Click on it and select Disk Utility.   See if you can erase the drive. 


If you cannot erase it, then click on each MX500 volume and click the "Unmount" button.   After unmounting all of the MX500 volumes, quit Disk Utility.    S ee if you can open the Apple System Profiler (or System Information).   I'm not sure if it will be located on the Utilities menu or under the Apple menu.    In the left pane, click on "SATA" and look for your MX500 in the right pane.    You need to see if it shows which disk number is associated with the MX500.   It should be in the form of "disk#".   If the MX500 is the only drive connected, then most likely it will be "disk0" or possibly "disk1".   Disregard any "s#" as that only indicates volumes/partitions on the drive.   


 Once all of the MX500's volumes have been unmounted, we want to destroy the existing partition information.   We will do this using the command line to zero out the beginning part of the drive.  For this we will need the Terminal app found on the Utilities menu.   I highly recommend that the only drive connected to your MBPro at this point should be the MX500 as the next command is a very dangerous command.  If you misidentified the SSD or mistype the next command you could accidentally destroy data on another drive.


sudo    dd   if=/dev/zero   of=/dev/diskN   bs=1M    count=1000

Replace the "N" in "diskN" with the number associated with the MX500 which you found using the System Profiler.  If the command fails, try a lower case "M" instead ("bs=1m").   I forget which one OSX uses.   If the MX500 is the only drive connected to the MBPro, then most likely it will be "disk0".   Do not guess at this.  Also this command will require your password as it needs administrator access to run.


If this works, quit the Terminal app and open Disk Utility again.   If you don't see the MX500 in the left pane, you need to click on the drop-down box under "View" and select "Show All Devices".   If you still don't see the MX500, quit Disk Utility and reopen it.  You should now be able to see the MX500 (this was a bug in early releases of High Sierra).   Now Erase the drive making sure the partitioning scheme is "GUID".    You may be given a choice of filesystems.   APFS is the new Apple filesystem and HFS+ journaled is the older filesystem.    In theory APFS should be the better choice, but being a new filesystem there still may be some compatibility issues with some hardware or even some apps.  After successfully erasing the MX500 quit Disk Utility.   If APFS doesn't work, try HFS+ journaled.


If destroying the partitions or erasing the MX500 was not successful, then you could try the above steps again, but connecting the MX500 externally using a USB to SATA Adapter.   This will tell us if there is an issue with the internal cable or controller.


If the above procedures does not allow you to repartition ("erase") the MX500, then I would try a Secure Erase of the MX500.   The easiest method for you would be to use Parted Magic.  An older free version can be downloaded from here which might work on your MBPro (the first download link there no longer works).  I've also never personally used it.  In order to Secure Erase the SSD, it must be installed internally in the MBPro.    If this does not work, I may be able to provide you with assistance using another method.


As far as cloning your original drive, I would recommend using Carbon Copy Cloner instead.   You should be able to run it on your original drive and clone it live (at least this used to be a feature).  It will also recreate a Recovery Partition for you which is necessary for using FileVault.


Another method would be to install a clean copy of High Sierra using Internet Recovery Mode.   Then during the setup phase, you get the option to use Migration Assistant to migrate your User Folder(s), settings and even your apps if you want.  Keep in mind some apps which have proprietary license keys (like MS Office or Adobe products) will probably need to have the keys re-entered.