M4-CT512 SSD Disk issue

Kilobyte Kid

M4-CT512 SSD Disk issue



I have a M4-CT512 that I used as my main disk on a MacBook Pro (used for about 6 months). Then I changed the main disk for a bigger one and put the M4-CT512 as secondary disk on my Thinkpad 430s using an Ultrabay Adapter (used for about 6 months). It worked well but suddenly it stopped working. I searched for solutions at the time, but didn't find and wasn't with time back then to expend more time trying, then I took of the disk and put in my drawer to find a fix later.

Now I had a little time to try to fix it.

Well, at first, I looked for a firmware update as was able to flash the latest firmware (it was showing version 000h and now I have 070h installed)

Tried to format the disk on Windows, Mac and Linux with no luck.

Currently I plugged the disk on a Cavalry external USB adater and I'm running the badblocks command on linux and it is take a really long time (more then 10 hours by now), apparently marking almost all sectors as badblocks.


So, by now, I would like to ask. How to have sure that this disk is really dead?


Anyone could help me with this?


Thanks a lot



The result of smarctl -a /dev/sdd is:

smartctl 6.5 2016-01-24 r4214 [x86_64-linux-4.4.0-31-generic] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

Model Family:     Crucial/Micron RealSSD m4/C400/P400
Device Model:     M4-CT512M4SSD2
Serial Number:    000000001225090DD26B
LU WWN Device Id: 5 00a075 1090dd26b
Firmware Version: 070H
User Capacity:    512,110,190,592 bytes [512 GB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    Solid State Device
Form Factor:      2.5 inches
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ACS-2, ATA8-ACS T13/1699-D revision 6
SATA Version is:  SATA 3.0, 6.0 Gb/s (current: 3.0 Gb/s)
Local Time is:    Tue Mar 26 14:34:12 2019 UTC
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x86)	Offline data collection activity
					was aborted by the device with a fatal error.
					Auto Offline Data Collection: Enabled.
Self-test execution status:      (   0)	The previous self-test routine completed
					without error or no self-test has ever 
					been run.
Total time to complete Offline 
data collection: 		(  100) seconds.
Offline data collection
capabilities: 			 (0x7b) SMART execute Offline immediate.
					Auto Offline data collection on/off support.
					Suspend Offline collection upon new
					Offline surface scan supported.
					Self-test supported.
					Conveyance Self-test supported.
					Selective Self-test supported.
SMART capabilities:            (0x0003)	Saves SMART data before entering
					power-saving mode.
					Supports SMART auto save timer.
Error logging capability:        (0x01)	Error logging supported.
					General Purpose Logging supported.
Short self-test routine 
recommended polling time: 	 (   2) minutes.
Extended self-test routine
recommended polling time: 	 (  39) minutes.
Conveyance self-test routine
recommended polling time: 	 (   3) minutes.
SCT capabilities: 	       (0x003d)	SCT Status supported.
					SCT Error Recovery Control supported.
					SCT Feature Control supported.
					SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
  1 Raw_Read_Error_Rate     0x002f   100   100   050    Pre-fail  Always       -       86
  5 Reallocated_Sector_Ct   0x0033   100   100   010    Pre-fail  Always       -       16384
  9 Power_On_Hours          0x0032   100   100   001    Old_age   Always       -       12259
 12 Power_Cycle_Count       0x0032   100   100   001    Old_age   Always       -       1322
170 Grown_Failing_Block_Ct  0x0033   100   100   010    Pre-fail  Always       -       4
171 Program_Fail_Count      0x0032   100   100   001    Old_age   Always       -       458
172 Erase_Fail_Count        0x0032   100   100   001    Old_age   Always       -       0
173 Wear_Leveling_Count     0x0033   100   100   010    Pre-fail  Always       -       1
174 Unexpect_Power_Loss_Ct  0x0032   100   100   001    Old_age   Always       -       162
181 Non4k_Aligned_Access    0x0022   100   100   001    Old_age   Always       -       819 547 272
183 SATA_Iface_Downshift    0x0032   100   100   001    Old_age   Always       -       0
184 End-to-End_Error        0x0033   100   100   050    Pre-fail  Always       -       0
187 Reported_Uncorrect      0x0032   100   100   001    Old_age   Always       -       1848
188 Command_Timeout         0x0032   100   100   001    Old_age   Always       -       0
189 Factory_Bad_Block_Ct    0x000e   100   100   001    Old_age   Always       -       183
194 Temperature_Celsius     0x0022   100   100   000    Old_age   Always       -       0
195 Hardware_ECC_Recovered  0x003a   100   100   001    Old_age   Always       -       107031
196 Reallocated_Event_Count 0x0032   100   100   001    Old_age   Always       -       4
197 Current_Pending_Sector  0x0032   100   100   001    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0030   100   100   001    Old_age   Offline      -       2
199 UDMA_CRC_Error_Count    0x0032   100   100   001    Old_age   Always       -       74
202 Perc_Rated_Life_Used    0x0018   100   100   001    Old_age   Offline      -       0
206 Write_Error_Rate        0x000e   100   100   001    Old_age   Always       -       458

Read SMART Log Directory failed: scsi error unsupported scsi opcode

Read SMART Error Log failed: scsi error unsupported scsi opcode

Read SMART Self-test Log failed: scsi error unsupported scsi opcode

Read SMART Selective Self-test Log failed: scsi error unsupported scsi opcode


4 Replies

Re: M4-CT512 SSD Disk issue

Looks like a lot of Reallocated Blocks.    It also has some Ultra-DMA CRC Errors which usually indicate a cable issue, but we don't know if they are current errors or ones which happened on one of your other systems.   It is also concerning about not being able to provide any SMART information about Errors, SelfTest logs, etc.   


I would connect the SSD to one of the internal SATA controllers which uses AHCI mode and perform a Secure Erase on the drive to see if a reset to factory defaults helps as it will also touch every NAND block.   You can also perform a Secure Erase using an eSATA port as well.   Do not do a Secure Erase while the drive is connected to USB as it probably won't work and it could cause other issues.

Kilobyte Kid

Re: M4-CT512 SSD Disk issue



thanks for your fast answer and help and sorry for taking so long to give feedback.


I did many other tests and now I have a little more info.


The smartctl command as I sent in the first post only works when using an external USB adapter. If I plug the driver using the ultrabay (which I believe is a SATA interface), the BIOS recognize the drive but when I try to run fdisk -l for instance, it cannot find the drive. The smartctl command don't work as expected either.

To make sure that the problem wasn't the interface, I tried to use the main SATA interface of my ThinkPad T430s and it took me a while to be able to do that as the Crucial M4 is a little fatter then other disks. I had to unmount my thinkpad to be able to fit the disk.


Now Im using a live ubuntu usb and trying to run some commands on the Crucial M4, but still no luck.I'm not a linux expert. Im using it because its looks like there are more tools for troubleshooting or fixing.


Tried to follow these instructions:





But the issue now is that on "direct" SATA the drive has more issues them before.


Any ideas on what to do? Give up as it is probably damaged with no recovery options?


Thanks again


Now what I get is:

ubuntu@ubuntu:~$ sudo smartctl -a -T verypermissive /dev/sda
smartctl 6.6 2017-11-05 r4594 [x86_64-linux-4.19.0-13-generic] (local build)
Copyright (C) 2002-17, Bruce Allen, Christian Franke, www.smartmontools.org

Short INQUIRY response, skip product id

SMART Health Status: OK
Current Drive Temperature: 0 C
Drive Trip Temperature: 0 C

Read defect list: asked for grown list but didn't get it
Error Counter logging not supported

Device does not support Self Test logging


ubuntu@ubuntu:~$ sudo hdparm -I /dev/sda
HDIO_DRIVE_CMD(identify) failed: Input/output error


Another test using USB adapter


ubuntu@ubuntu:~$ sudo hdparm -I /dev/sdb


ATA device, with non-removable media
	Model Number:       M4-CT512M4SSD2                          
	Serial Number:      000000001225090DD26B
	Firmware Revision:  070H    
	Transport:          Serial, ATA8-AST, SATA 1.0a, SATA II Extensions, SATA Rev 2.5, SATA Rev 2.6, SATA Rev 3.0
	Used: unknown (minor revision code 0x0028) 
	Supported: 9 8 7 6 5 
	Likely used: 9
	Logical		max	current
	cylinders	16383	16383
	heads		16	16
	sectors/track	63	63
	CHS current addressable sectors:    16514064
	LBA    user addressable sectors:   268435455
	LBA48  user addressable sectors:  1000215216
	Logical  Sector size:                   512 bytes
	Physical Sector size:                   512 bytes
	Logical Sector-0 offset:                  0 bytes
	device size with M = 1024*1024:      488386 MBytes
	device size with M = 1000*1000:      512110 MBytes (512 GB)
	cache/buffer size  = unknown
	Form Factor: 2.5 inch
	Nominal Media Rotation Rate: Solid State Device
	LBA, IORDY(can be disabled)
	Queue depth: 32
	Standby timer values: spec'd by Standard, with device specific minimum
	R/W multiple sector transfer: Max = 16	Current = 16
	Advanced power management level: 254
	DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5 
	     Cycle time: min=120ns recommended=120ns
	PIO: pio0 pio1 pio2 pio3 pio4 
	     Cycle time: no flow control=120ns  IORDY flow control=120ns
	Enabled	Supported:
	   *	SMART feature set
	    	Security Mode feature set
	   *	Power Management feature set
	   *	Write cache
	   *	Look-ahead
	   *	Host Protected Area feature set
	   *	WRITE_BUFFER command
	   *	READ_BUFFER command
	   *	NOP cmd
	   *	Advanced Power Management feature set
	    	SET_MAX security extension
	   *	48-bit Address feature set
	   *	Device Configuration Overlay feature set
	   *	Mandatory FLUSH_CACHE
	   *	SMART error logging
	   *	SMART self-test
	   *	General Purpose Logging feature set
	   *	64-bit World wide name
	    	Write-Read-Verify feature set
	   *	{READ,WRITE}_DMA_EXT_GPL commands
	   *	Gen1 signaling speed (1.5Gb/s)
	   *	Gen2 signaling speed (3.0Gb/s)
	   *	Gen3 signaling speed (6.0Gb/s)
	   *	Native Command Queueing (NCQ)
	   *	Phy event counters
	   *	NCQ priority information
	    	DMA Setup Auto-Activate optimization
	    	Device-initiated interface power management
	   *	Software settings preservation
	   *	SMART Command Transport (SCT) feature set
	   *	SCT Write Same (AC2)
	   *	SCT Error Recovery Control (AC3)
	   *	SCT Features Control (AC4)
	   *	SCT Data Tables (AC5)
	   *	Data Set Management TRIM supported (limit 8 blocks)
	   *	Deterministic read data after TRIM
	Master password revision code = 65534
	not	enabled
	not	locked
	not	frozen
	not	expired: security count
		supported: enhanced erase
Logical Unit WWN Device Identifier: 500a0751090dd26b
	NAA		: 5
	IEEE OUI	: 00a075
	Unique ID	: 1090dd26b
Checksum: correct

Re: M4-CT512 SSD Disk issue

What is the manufacture date of this laptop and what chipset & SATA controller does it use?  


If you want to use Linux to test a system, then I recommond using Knoppix as it includes most of the necessary tools and it will boot just about any system 32bit or 64bit.


You should keep an eye on Attribute 199 Ultra-DMA CRC as any errors here usually indicate a cable/connection issue and it would be nice to know which interface may be contributing these errors.


With the SSD installed internally, run the following command to check for any issues:

sudo dmesg -t | grep -iE '^ata|^scsi|^raid|^ahci|^sd'

The output of this command will include more than just references to the SSD, but it should cover all the bases (I hope).


You can compare the communication while connected with USB by booting Ubuntu/Knoppix with the USB SSD disconnected and running the following command:

sudo  dmesg  -tw

This will show the end of the system log and it will automatically display the new entries when you connect the USB SSD.  Press Ctrl + C to terminate the command.


You may want to run the following command to identify the chipset & drive interfaces in this laptop:



It is unusual to see smartcl & hdparm not work on an internally connected drive.  Usually you see this with some USB adapters & RAID controllers.


If you don't have any other computers to use for testing this SSD internally, then it might be worth putting this SSD back into the MBPro and seeing how it behaves.  You should be able to Secure Erase the SSD while it is installed in the MBPro using Knoppix and this guide.

Kilobyte Kid

Re: M4-CT512 SSD Disk issue



thanks again for your answer. Unfortunatelly I'm busy again had not much time to work on it. But I tried to put it back on MBP and the disk isn't even recognized. I tried booting using internet recovery and plugged the disk on the main SATA.

As the Thinkpad is my main computer, it is harder for me to make tests with it and other computers that I have access are harder to make the job like a MacAir or a Microsoft SurfaceBook.

But as soon I can I will make these tests and let you know.


Thanks again