M500: TCG iusse and cannot revert PSID

Kilobyte Kid

M500: TCG iusse and cannot revert PSID

Since Windows 10 Creators update sometimes I have system boot freeze and - very rarely - system freeze when the OS is running.

In the windows event viewer I got a couple of EnhancedStorage-EhStorTcgDrv (event id 10) errors per day, that looks like this:



A TCG Command has returned an error.
Desc: AuthenticateSession
Param1: 0x1
Param2: 0x60000001C
Param3: 0x900000006
Param4: 0x0
Status: 0x12

I never turned on bitlocker on this device, nor I encrypted it in any way. TPM is turned off in system BIOS, secure boot is on.



I already tried to use the Crucial Storage Executive but I was able to do nothing (of course I used another hard drive as system drive).

I already tried to add the registry key to disable TCG before Windows installation, but It didn't solved anything.


This is a screenshot of what I get wen I run MSCLI: https://i.postimg.cc/hjZ4ThVm/help-crucial.png


I whish to totally stop those system hangs, which happens mostly on the very first seconds of system boot, since the SSD is still working fine (except this issue).


System config:

Windows 10 x64 1809, last updates installed, 16GB DDR4, AMD Ryzen 5 1500x, ASUS C6H x370 motherboard (last bios with AGESA installed), Crucial M500 (firmware MU05), other non-TCG capale hard drives etc...


7 Replies

Re: M500: TCG iusse and cannot revert PSID

Typically bitlocker is enabled during Windows 10 (also 8 and 8.1) installation. Unfortuantley this is enabled silently by W10 installer and user is not notified about that nor has an option to skip this.
The trick with registry entry doesn't work in case the drive already is in TCG enabled state so it won't work in your case. You should successfully perform PSID revert before attempting this workaround.


Did you try 'graphical' Crucial Storage Executive to perform PSID revert? Or was it mscli command line tool?
During your PSID revert attempt, did you have AMD chipset and SATA drivers installed?

How do I know what memory to buy?
Shop for your region: US | UK | EU | France |
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: M500: TCG iusse and cannot revert PSID

Hi, thanks for the replay.

Unfortunately BitBlocker is disabled since the installation, moreover the TPM module and any other forms of encryption provided by the hardware were disabled, and are still disabled, in the motherboards firmware.

I also tried both CLI and GUI versioon of Crucial Storage Executive without success, in the GUI version simply the SSD is not listened in the PSID revert tab.

All sata devices are managed via AMD SATA controller on ACHI mode, AMD do not provides simples ACHI SATA drivers for Windows 10 on this platform, only for RAID mode (which is not enabled). The ACHI SATA controller where all SATA devices are connected is identified as PCI\VEN_1022&DEV_43B5&SUBSYS_10621B21&REV_02 and AMD does not provide a driver at all  for this device even on older Windows versions (7/8/8.1). All other AMD chipset drivers are installed and up-to-date.


Re: M500: TCG iusse and cannot revert PSID

You cannot PSID revert a boot drive using CSE.  You could create a Parted Magic USB drive or a sedutil boot disk and perform the PSID revert that way.   


If you choose to use sedutil, then make a USB boot disk using one of the Rescue images here, and follow the instructions here.  The instructions unfortunately assume using the utility under Windows and the Rescue image is Linux based.  You will need to modify the commands to a Linux format.  For example:  The output of the --scan in Step 1 will show your SSD in the format as "/dev/sdX".  For Step 2, modify the path to the SSD as follows:


sedutil-cli  --query  /dev/sdX

Modify Step 3 in the same way.


Kilobyte Kid

Re: M500: TCG iusse and cannot revert PSID

I tried to revert the PSID using another driver as a boot unit.

I also tried using sedutil without success.

Kilobyte Kid

Re: M500: TCG iusse and cannot revert PSID

OK I was able finally to disable to turn off locking on the device. Hope this issue will not happen again... And for the love of all your customers, talk with Micron engineers or Microsoft engineers and try to solve this thing since I was not the only one affected and probably most of people would buy a new SSD from another brand.


Re: M500: TCG iusse and cannot revert PSID

@Alessio89 Can you share the steps you used to resolve the issue?

Kilobyte Kid

Re: M500: TCG iusse and cannot revert PSID

I build a bootable stick with rufus (https://rufus.ie/) and used an update linux 64 bit image with sedutil and followed again the instructions you suggested.

Before booting directly from motherboard firmware I also deleted the Windows secure boot keys and switched to "Other" from "Windows" in the secure boot section of my ASUS motherboard.


Before erasing everything I also tried also to follow the "Remove-OPAL" procedure (https://github.com/Drive-Trust-Alliance/sedutil/wiki/Remove-OPAL) but without success (since it required a Admin1Password or at least a envcryption password I never set by myself), so I had to erase everything with PSID revert (https://github.com/Drive-Trust-Alliance/sedutil/wiki/PSID-Revert). After thatfinally the "lockingEnabled" variable was set to "N".


I also add the registry key to prevent Windows to active TCG again (I also switched back to "windows" mode secure boot in the MB firmware).


This time looks everything work, thanks again for your help.