MX200 - 500gb SSD not responding

Kilobyte Kid

MX200 - 500gb SSD not responding

Hi everyone


I'm really hoping someone will be able to help me.


I had my above SSD installed on my previous MacBook Pro (early 2011, i7 quad core, running El Cap) as the internal boot drive. This computers graphics card failed, which inturn caused the main board to fail. Due to the age of the  machine it was advised not to attempt a repair. I've recently purchased a new MacBook Pro (Mid 2015, i7 quad core, pre installed with High Sierra). I removed the SSD from my previous Macbook Pro and trasfered it into an external casing, using USB 3


Everything was perfect and worked 100% on my new laptop. I was able to get all my work files off the drive, it was mounting perfectly etc etc. I think the trouble started when I noticed the "hidden files" on the drive were taking up a lot of space, so I removed some of them. I did this, since ultimately I was going to reformat the drive and it was not going to be used as a bootable drive but just as a storage drive, so all i needed on the drive were my work files, which I retrieved. The drive stopped working. It wouldnt mount etc. I also noticed that  if I rebooted my machine with the external drive plugged in, it would take an exceptionally long time to boot (5-7mins). I've tried the following through disk utility: first aid, erasing, and retoring onto the drive, all of which just cause the process to hang / get stuck (for hours). I tried all if this through recovery mode too, same thing. Here are screen grabs I've taken during the process (sorry, one is slightly blurry). When I'm in Disk Utility, evetually the disk loads into the left column (takes ages) as you can see. I just cannot follow through any of the processes. I've also tried using DriveDX, but since S.M.A.R.T status no longer seems to be supported on this drive, I'm not able to get a report (the app asked me to install a driver, which I did, but it still didnt work). The SSD is about 2 years old, never been dropped etc, and was working perfectly, with no errors, crashes during copying etc etc


I've also removed the SSD from the new external casing and inserted it into another external casing, just to check if it was the cable / plug, same problem..


I really don't want to have to buy a new drive, so I'm hopping someone knows how to help me?





2 Replies

Re: MX200 - 500gb SSD not responding

Some controllers don't pass the SMART commands to the external drive.   OSX does require the installation of a SCSI driver in order to be able to possibly transfer the SMART commands to an external drive.


OSX is really dumb sometimes when it comes to drive & filesystem issues.   Your best bet is to identify the device ID of the SSD.   It will be in the form of "diskX" where "X" is a number, most likely it will be "2" if you don't have any other devices or volumes mounted.  If you have other devices/volumes mount I suggest you remove them so nothing happens to them during this procedure.    You can confirm this device ID using Disk Utility or even System Profiler under USB or Storage.   If the MX200 is mounted, then unmount it using the Disk Utility GUI.


Once you identify the proper device ID, open the Terminal app located in the Utilities folder.    Issue the following command from the Terminal replacing the "X" with the correct number for the MX200.  If you select the wrong device ID you could destroy a Volume you don't want to touch.  Don't worry about the extra information such as "s1" etc. as that is just the partitions.    This command will write zeroes to the drive destroying the partition information & some of the filesystem (about 2GB).

sudo   dd   if=/dev/zero   of=/dev/diskX    bs=20m    count=100

Afterwards, launch Disk Utility GUI again and try to create a new Volume on it.  If you are using High Sierra, you will need to select "View All Devices" before Disk Utility GUI will even see the blank MX200. See if that solves your problem. 


FYI,  Crucial recently released a new firmware update for the MX200 SSDs, but it requires the SSD being installed internally in a system or via eSATA in order to update it.  If you do this, then I would suggest performing a Secure Erase afterwards to reset the MX200 as this will reset it performance as well.

Kilobyte Kid

Re: MX200 - 500gb SSD not responding

Thanks for your instructions HWTech, I'm going to try this and will post my outcome as soon as I've done it. I'm holding thumbs this will work!