MX200 Firmware Update Don't Work - Help Needed!

Kilobyte Kid

MX200 Firmware Update Don't Work - Help Needed!

I have four MX200 SSD's.  Two are attached to ASRock Z97 Extreme6/4790K systems with a Sandisk Extreme Pro SSD as the W10 boot drive.  The Crucial online update system works as advertised.


The other two MX200 SSD's are attached to an ASRock Z97 Extreme6/4790K system with a Samsung 960 EVO drive and a ASRock X370 Taichi/1700X system with a Samsung 960 EVO as the W10 boot drive.  The Crucial onlie update system does not work on these systems.  It says the drive have an "Invalid Firmware Directory".


I called Crucial Customer Technical Support and he said it could not possible be the online update's problem with the Samsung 960 EVO drives!!  He said try setting the BIOS to IDE and try again.  That did not work on the Intel system AND the AMD based system does not offer IDE as an option!!  He also said download the file to generate a CD boot version of the update program.  I downloaded the file unzipped it and made a CD using the ISO file.  I used The W10 burn feature to create the CD.  The CD created would not boot.  I used ImgBurn to create a CD from the ISO file and the CD would not boot.  the zip file I download was "" and the file I tried to use to make a boot CD included in the .zip file was "mx200_revMU04_bootable_media_update.iso".


I then removed one of the MX200 SSD's and took it to a system that had a BLACX external USB setup and tried to update the firmware.  Things looked like they might work but when the system tried to boot into the "whatever standalone program" the system hung.  Based on my experience with the Crucial updates to this point I was not surprised with another failure!


I have a bunch of Sanddisk, Samsung and Crucial SSD's and the only one that seems to have the old convoluted firmware update procedure is Crucial.  Maye it's time to update the software?  Anyway, before I give up and attach the two "problem"  Crucial SSD's to a system that has a Sandisk boot drive I would like to find out what I'm doing wrong since I can't even create the CD boot drive to give it a try.  Help would be appreciated.

3 Replies

Re: MX200 Firmware Update Don't Work - Help Needed!

You definately can't do it over USB - even though that was the one you mentioedn looked promising. Smiley Happy


To create a bootable CD, you MUST burn the ISO as an image - not a data disc.


If you have a USB pen drive handy, you can also create bootably USB drives from bootable ISO's.  I've used in the past for this with WIndows ISO's - though I've admittedly not tried it for Crucial firmware (but I can;t think of a reason it wouldn't work)

How do I know what memory to buy?
Shop for your region: US | UK | EU | France |
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: MX200 Firmware Update Don't Work - Help Needed!

Thanks for the response.  I've created many bootable CD's and USB's over the years and never ran into this problem until I met Micron! 


I gave up screwing around and took the "Problem" drives over to a system that did not have a Samsung 960 EVO installed and updated the drives using the Windows 10 version of the SSD update interface.  It went through all the convoluted reboot, update, reboot stuff and the drives are now updated to the latest version of the firmware whatever that worth. 


I still say that the Crucial/Micron update program has an issue with the Samsung 960 EVO drive.  But then ... when I called the Support person he just said it's my problem and the two drives must be messed up in some way.  I'll think twice before I buy another Crucial/Micron drive even though I been using them for a couple of years and never had an issue until I met Samsung's 960 EVO drives.


I sure hope someone from Crucial/Micron looks at this thread and acknowledges there is a firmware update program  issue.

Kilobyte Kid

Re: MX200 Firmware Update Don't Work - Help Needed!

Actually, I think it is possible to update the firmware over USB.

Believe I've done it with at least one Crucial SSD.

This shouldn't be taken as a recommendation to update the firmware over USB however, it is riskier than doing it over SATA.