MX300 275GB M0CR050 Firmware Revocation?

Bit Baby

MX300 275GB M0CR050 Firmware Revocation?

Hi there, I sent a message to the Crucial facebook page after some issues popped up last month concerning a fleet of laptops at my company using MX300 with firmware revisions M0CR050. I was told that they will not respond and to post my question (sort of rambling) here instead. This is by no means some kind of shout post with complaints or anything like that, but instead a slight concern I have after dealing with two failures of Crucial SSD's while running this older firmware revision. Also, before anyone asks, I did contact Crucial support when this issue was first found and we came up with a solution that essentially wiped the drives. 


So without further ado, here is my question. Was there something seriously wrong with firmware revision M0CR050 for at least the 275GB models? The issues we had affected two nearly brand new SSD's that were installed in a fleet of 8 lenovo laptops in our company. The SSD's were installed, and their firmwares were updates. The machines had no issues after a fresh installation of Windows on each machine. This went on for months, without incident. Within the last month or so, I had an employee notify me of one of the laptops that wouldn't boot. After checking the machine, it was determined that a read/write error were causing the boot partition to not function at all. I ran Lenovo's inbuilt disk diagnostics on the drive and determined that the drive failed the "Smart Test" (vague I know) and failed the "Read Speed" test as well. After using a different system to attempt recovery of the drives data, I found that there drive was in fact, completely unusable. I contacted Crucial support after this issue first came to light and informed of all the diagnostics and troubleshooting I had done. I had updated the firmware to the most recent M0CR060 by this time which did not resolve the issue, and could not seem to get the damaged files on the disk repaired. I was asked by Support to wipe the drive and reinstall the operating system (the nuclear option), to see if the drive began to function properly. 

Now mind you, after all the troubleshooting I had done, and all the issues the drive was giving me, I had no hope that reinstalling the operating system would work, but alas, I reinstalled Windows without a hitch. Upon completion, I ran all the same diagnostic tools on the drive again, and performed a couple of bench marks as well to ensure the drive was stable. As unexpected as it was, the drive was back to normal, though I lost all that data. This incident caused me some serious alarm because once I had found that the data was un-savable, I had all laptops brought back in to get the firmware update and to check all the drives to determine if any of them were experience the same failures of the first drive. Of the 8 drives that were in the field running the old M0CR050, another two machines had similar failures though in different partitions of the drive. These errors, once again, like clockwork, could not be repaired at all. I fully formatted the drives, then reinstalled the operating systems. These drives now all have the most current firmware and no other machines have the same issue. 


So, why am I writing this overly lengthy story here? Because I am curious. I use a lot of Crucial flash products in a lot of machines at work here, and in my home systems. My home system has 6 MX300's running in it, and after this situation I pulled them all and updated them to prevent issues in the future. This post is just a question to Crucial I suppose, the firmware revision notes for M0CR050 and M0CR060 are slightly vague as for the importance of updating the drives to the newest revisions. They list that SMART error attribute 198 would not reset properly, and I have a feeling that is what might have been the issue all along.


If this older firmware has issues that can cause excessive data loss, shouldn't Crucial notify everyone here that anyone running the older firmware should update prior to the issue occurring? Surely I couldn't be the only one that had these issues, though Googling my problem yielded no serious results. The only common denominator here is the firmware version M0CR050. 


Sorry for rambling on, I just figured if anyone else has this issue, they should know that they are not alone. 

I hope everyone is having a great new year!


2 Replies

Re: MX300 275GB M0CR050 Firmware Revocation?

I'm not aware of any serious firmware related issues.


And whilst they are vague with their changelogs, they do indeed note if its important for you to upgrade - which implies that it's not from their point of view...

See the post dated ‎01-13-2012 07:29 PM from here for an example:

That was the last time there was a serious wide reaching firmware bug I'm aware of...



How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?

Re: MX300 275GB M0CR050 Firmware Revocation?

I've experienced issues with these drives myself with the older M0CR040 firmwares causing a similiar issue where the SMART Self Test will fail and the SSD will not automatically remap the bad blocks.   What worked for me was first updating to the latest firmware and then performing an ATA Secure Erase on the SSD which is basicly a reset and erase of the SSD.   Doing this got the bad blocks to be reallocated and allowed the SMART Self Test to complete successfully.    So far I haven't seen any further issues.   Of course the ATA Secure Erase does erase the drive requiring an OS reinstall.