MX500 Really slow on 4K

Bit Baby

MX500 Really slow on 4K

Hi!

 

I just purchased a new MX500 2TB and installed a fresh windows on it.

 

I was doing some benchmarks and I don't know why, my HDD is WAAAAAY slower than any other on forums or reviews on 4K and I don't know why or if is maybe a faulty drive.

 

It is running on:

- 5820K

- 16GB of ram

- x99 motherboard

 

on the bios is correctly configured as ssd, but I tried as hdd and doesn't change anything.

 

This is my drive 


And this is other people or reviews

 

Any idea?

10 Replies
Highlighted
JEDEC Jedi

Re: MX500 Really slow on 4K

Benchmarking drives is far from an exact science.  If you ran it back to back you'd likely get wildly different numbers.  Chipset and sata driver will massively affect it, as will background tasks (particulary AV)

 

I've got that exact drive on the way myself (hopefully next week) also going into an X99 so I can give you a like for like comparison soon!

Bit Baby

Re: MX500 Really slow on 4K

Yeah I know, I benchmarked the drive just after the installation, no AV, nothing on the background that could give false numbers.

 

I re-run the benchmark like 10 times changing things on bios and trying everything, nothing changed those slow 4K, so I'm a bit at loss here.

JEDEC Jedi

Re: MX500 Really slow on 4K

@targetbsp is spot on as so much can affect the results.  Most review sites have a specialized Windows installation and are testing a non-boot drive so results can be more consistent.  They also provide average results from several test runs so you don't always see the worst.   

 

If you are using Win10, it does so much in the background which is very hard to detect which can affect performance as well.  I'm not saying there is not an issue with the SSD, but you have a lot of work to narrow it down.

 

Also you need to make sure the partitions are on a 4k boundary or it will seriously affect performance.

JEDEC Jedi

Re: MX500 Really slow on 4K

This is what I got.  S ame drive, same chipset as you.  And as you can see, it varies wildly from both yours and the reviewers benchmark.  I became convinced years ago that these behcnmarks are completely worthless. Smiley Very Happy

They're OK for review roundup purposes for comparting different models under the same conditions.  But I'm unconvinced in their usefulness for comparing drives in one system to another.

 

Capture.JPG

 

If you want to go score chasing though - it will be all about killing your chipsets power saving features.  High performance Windows profile, no CPU throttling down to lower power states and speeds, disable sata power saving features etc.  It's not worth it to run the drive that way.  But worth having a play if you wanna get a 'high score' to see what it'll do. Smiley Happy

 

JEDEC Jedi

Re: MX500 Really slow on 4K

Well that cloen went very pear-shaped and somehow put 6TB of partitions on a 2TB drive. Smiley Very Happy  So I have no idea if the partition was aligned in the above test since the starting address doesn't even exist on the drive lol.  Trying this again...

Bit Baby

Re: MX500 Really slow on 4K

can't see the image, just a triangle

JEDEC Jedi

Re: MX500 Really slow on 4K


@mrpaco wrote:

can't see the image, just a triangle


Images on here need authorised by mods before anyone other than the poster can see them.

JEDEC Jedi

Re: MX500 Really slow on 4K

And with a partition layout that actually makes sense! A boost on the 4K reads and the queued 4k writes:

 

Capture.JPG

 

The high queue 4k's are still way doen on the reviewers.  Though that's not a queue depth you'd ever see in the real world.

 

My system is using the latest iRST drivers.  Are you? https://downloadcenter.intel.com/product/55005

JEDEC Jedi

Re: MX500 Really slow on 4K

Then I trimmed the free space using windows optimiser ran it again and got wildly worse.  This is a useless benchmark lol

 

Capture.JPG

 

Let's try some SSD oriented benchmarks next...