MX500 m.2 not detected any more

SOLVED
Highlighted
Kilobyte Kid

MX500 m.2 not detected any more

System:

Asrock Z370 Taichi Bios 3.10

8700k

16gb gskill

1080ti

MX500 1TB m.2

 

When I first installed the drive, I used the M2_3 slot on my motherboard and disconnected all SATA devices. On first boot, it wasn't detected by bios. This being my first m.2 drive, I figured it may need to reseat it. After reseating it, it was detected by bios listing the model number of it in the boot menu. I continued on to install windows 10 pro via USB. The drive was listed and I was able to format it. The installation got stuck at 24% of 'Getting files ready for installation' for about 30 minutes. I decided to shutdown and attempt again. Unfortunately, the drive wasn't detected by bios or windows installation. I installed the drive into each of the other m.2 slots on the mobo, same result. After reseating about 30 times or so I was able to see life of the drive in bios and windows but it only showed up as 1000mb and I was not able to format or anything. Also in my testing, I noticed an LED on the drive that would either be green or orange. If the light was green on boot, bios was accessible immediatly like normal, but if it was orange, bios would take about a minute to come up after pressing delete. What does the orange and green LED signify?

 

I have checked all my connections, cleared cmos, loaded defaults, changed any setting in bios that would relate to SATA/drives but no luck. Installed my previous SSD to see if I could see the m.2 in disk management or device manager but nothing shows up for it.

 

I have another system with an Asrock AB350M Pro4 which has 1 SATA m.2 slot. Same story with that pc.

 

I posted a thread last night but it looks like it didn't take.

2 Replies
JEDEC Jedi

Re: MX500 m.2 not detected any more

As a last resort make sure your motherboard firmware is up to date  and blow some compressed air in the M.2 slot.  You seem to have covered all the bases as far as I can tell.   After that, it sounds like you may have a defective SSD.  You could try contacting Crucial Tech Support directly to see if they have any other advice or you could just RMA it.

 

If you RMA it, I would suggest installing the replacement into your other motherboard first as a data drive just to make sure it is working.   This will help you troubleshoot just in case it happens again as it would point to a problem with the system damaging the SSD (either faulty motherboard or power supply).   Nothing worse than getting two "bad" parts and not knowing how to proceed.  It is a little extra work, but I highly recommend it from personal experience.  Also make sure the computer is unplugged from the power cord when installing or removing it (some people do forget this).   

 

I'm not sure what the LED represents as I haven't used a Crucial M.2 drive yet.

 

Good Luck.

 

Kilobyte Kid

Re: MX500 m.2 not detected any more

I RMA'd it after contacting support. Tried it in other PC first, detected fine and was able to initialize it. Installed in main PC, same story. Installed windows without issue after that. Looks like a solid LED signifies an issue either green or orange.