MX500, very high write amplification

JEDEC Jedi

Re: MX500, very high write amplification


@s12a wrote:

Windows power plan is set to "High Performance" and after enabling the bits for setting it in advanced options, AHCI link state power management when plugged in appeared to be already set to not initiate DevSleep. On battery mode it was set to HIPM+DIPM; I've set it to active as well just in case.

That is weird that even despite all of this registry, power plan and Intel RST LPM modifications your power-on hours are still not in line with real-time hours. Could you please re-enable "Hot plug' option in BIOS for the SATA port the MX500 is connected to?

______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France |
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: MX500, very high write amplification


@bogdan wrote:

That is weird that even despite all of this registry, power plan and Intel RST LPM modifications your power-on hours are still not in line with real-time hours.


To clarify, the Intel RST drivers were installed on a different PC with an old Windows 10 installation. However, I also set up there "Active" AHCI Link State Power Management and the High Performance power plan without apparent change in drive behavior (both slow power on hours and write amplification). Furthermore, processor and processor package C-states were also disabled for a prolonged, period without any apparent change (it is known that for example enabling C6 state can decrease slightly random read/write SSD performance, so I thought that it could have helped).

 

On the computer I'm using right now (different hardware configuration, but same Intel chipset) and of course the same SSD, I have performed the tests described in the latest posts, but I haven't installed the Intel RST drivers yet. I'm using a fairly fresh Windows 10 installation after having secure erased (sanitized) the SSD.

 

Furthermore, yesterday I tried changing the SATA controller onto which the SSD is connected, from the native Intel one to the secondary ASMedia SATA controller, which does not have any relevant option to be set in the BIOS. Doing this with the PC still turned on did not seem to solve the write amplification behavior on a very short term, and after cycling SSD power, power on hours still appeared to increase slowly.

 

The bright blue line below shows power on hours over the past 24 hours (linear values on the right Y axis). The first dashed line is when I swapped (in the BIOS screen, then rebooting onto Windows) SSD SATA cables on the other SATA controller, while the second and third vertical dashed lines are when I cycled PC/SSD power on/off.

 

image.png

 


@bogdan wrote:
Could you please re-enable "Hot plug' option in BIOS for the SATA port the MX500 is connected to?

After posting this comment I will try to connect the SSD(s) back to the native Intel SATA controller and try this.


For more information and for the record, below are the latest SMART attributes from Crucial Storage Executive (click to enlarge).

 

image.png

 

Kilobyte Kid

Re: MX500, very high write amplification


@s12a wrote:

@bogdan wrote:
Could you please re-enable "Hot plug' option in BIOS for the SATA port the MX500 is connected to?

After posting this comment I will try to connect the SSD(s) back to the native Intel SATA controller and try this.


For the record, here are a few photos. I have cycled computer power twice (using Shutdown from the OS as to not cause an increase in Unexpected Power Loss count) in the process:

 

fr_20_size1024.jpg

fr_18_size1024.jpg

fr_19_size1024.jpg

Kilobyte Kid

Re: MX500, very high write amplification

@s12a wrote:

@bogdan wrote:
Could you please re-enable "Hot plug' option in BIOS for the SATA port the MX500 is connected to?

After posting this comment I will try to connect the SSD(s) back to the native Intel SATA controller and try this.


About 3 days later, I can say that this did not fix either issue:

 

  1. About 24 hours after power cycling the SSD, 1 GiB FTL page write spikes started appearing, causing a slow rise in write amplification.
  2. Power on hours still increased slower than real-time (almost 72 hours have passed so far, while the count from SSD attributes has increased by less than 24 hours).

I am starting to think that this (the anomalous WAF, at least) might be something related with the amount of time passed since the SSD was last power cycled, which could in part explain why not everybody might be seeing it.

 

 

The red dashed line in the graph below shows when the SSD was power cycled and the "Hot Plug" option in BIOS enabled again on the native (Intel) SATA controller as suggested. The computer was never turned off over this period. The bright blue line shows Power On Hours Count (linear values on the right Y axis).

 

20190412-15.jpg

 

The WAF since I last power cycled the SSD is currently about 3.09x, but it's 4.52x (and rising) since these spikes started appearing. If it wasn't for them, it would be about 1.25-1.35x, which means that the SSD at the current average Host Write rate would wear up at a rate roughly 2.5-3.0 times lower.