MacBook Pro does not recognize the new installed SSD

Kilobyte Kid

MacBook Pro does not recognize the new installed SSD

Hi Community


Device: Apple MacBook Pro 13 inch
Year: Mid 2012
Model: A1278

Identifiers: MD101LL/A* - MacBookPro9,2

Processor: 2,5 GHz Intel Core i5


I replaced the old HDD with a new Crucial MX300 SSD (Part Number CT525MX300SSD1), and booted my MacBook Pro with Option-Command-R, and was already on the MacOS Utilities screen, to format the new boot disk through of the Disk Utility, the connected unit SSD does not appear, to proceed with the formatting (see attached pic).
What to do ?



7 Replies
Kilobyte Kid

Re: MacBook Pro does not recognize the new installed SSD

The same happened to me. I solved it formating on a terminal with diskutil (you have to know first the disk number that you can get with 'diskutil list'


Kilobyte Kid

Re: MacBook Pro does not recognize the new installed SSD

Thanks for your reply.
I have no idea how to do that.
Could you please share a link where explains step by step how to do it?

Kilobyte Kid

Re: MacBook Pro does not recognize the new installed SSD

First, disconnect any external disk you may have to prevent erasing the incorrect disk..

In recovery mode (Command+Option+R), there is an option Utilities->Terminal which opens a command line.

First get the number of your disk with

diskutil list

you'll see something like




Do not confuse your internal physical disk with the disk image the Recovery process mounts. You will know which one is the right one because of the size (256 GB, 512 GB, etc). The disk image is only 2 GB size.

Let's say in your case is '0' de number.

Then you run the formating process

#diskutil eraseDisk JHFS+ DiskName /dev/disk0

You can choose different file systems. It does not matter because after showing on the diskutil GUI next time you can re-format to any format.

'DiskName' is only a label. You can choose whatever you want.

JHFS+ is Journaled HFS Plus File System


I suggest googling 'diskutil eraseDisk' to get more info in order to feel comfortable about the process.


Good luck!

Bit Baby

Re: MacBook Pro does not recognize the new installed SSD

This post deserves a bump.


I just installed a MX500 1TB SSD into a 2009 13" Macbook Pro (MacbookPro 7,1) and it wasn't being listed in Disk Utility.


I then followed the instructions here and opened Terminal, ran the command diskutil list and saw that the SSD was /dev/disk0 (was able to confirm the exact drive based on the size of the drive listed).  I then ran the command #diskutil eraseDisk JHFS+ "Macintosh HD" /dev/disk0 and after it completed the erase and format process, I close Terminal and reopened Disk Utility and the disk was listed.


1 item of note, in the command #diskutil eraseDisk JHFS+ "Macintosh HD" /dev/disk0, "Macintosh HD" can be replaced with any name you want to give the drive.  If it has a space in it, then it needs quotes around it (and if no space, no quotes are needed).

Bit Baby

Re: MacBook Pro does not recognize the new installed SSD


if the way you installed this SSD become to dispose of the preceding internal HD and install the SSD in its vicinity, with out formatting the new SSD and putting in a bootable working machine first, then there is no operating system or formatting software at all.

What steps have you ever already taken? If you could give us a detailed listing of the matters you've got already completed, in order, it'll be less complicated to determine wherein the hassle is.

A not unusual technique to replace an inner boot HD with an SSD would be to:

attach the SSD as an outside pressure first thru USB/FireWire/ Thunderbolt
use Disk utility to format the SSD
clone the running machine+user statistics from the internal HD to the external SSD the use of Disk software, SuperDuper! or Carbon replica Cloner (you can also do a smooth working gadget install by means of downloading an installer from the App save and putting in it on the new power)
then open up the computer and switch the drives
That manner, once you restart the reassembled pc, you may as a minimum make sure that there's a power with a bootable working system available. if you're following the method i've mentioned, it's smart to strive booting from the brand new external SSD earlier than putting in it internally, simply to ensure the pc acknowledges the drive as bootable.

Crucial Employee

Re: MacBook Pro does not recognize the new installed SSD





One thing that you can also try if running into this issue would be to check the "view" button that is on the top left hand corner of Disk Utility.  The image that you provided appears to only be showing volumes that are currently on hard drives. 


Since the new Crucial SSD has not yet been initialized or formatted, it will not show up in disk utility when the view button is set to only show volumes.  By clicking the view button in Disk Utility, you can select the option to show all devices that are connected instead of just volumes.  This should make the Crucial SSD show right up and you can continue on with with formattting and installing an image.  This may not work in every situation, but is something to check if others are running into similar issues.

Crucial_Ryan, Micron CPG Support, US

How do I know what memory to buy?
Shop for your region: US | UK | EU | France |
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Bit Baby

Re: MacBook Pro does not recognize the new installed SSD

Thanks guys, I've experienced the same problem and I did the following as recommend here. For me what happened was that at the first time the diskutil didn't see the disk so I removed and reinstalled manually, after that I runned the diskutil command and could follow the steps because disk0 was not been shown in the list, but after the second attempt (restart holding command+r) everything worked perfectly and now the MacBook is downloading the Os Smiley Happy
(Last update, after some attempts, when it lasts 5 minutes to finish the installation I get a kind of error and cannot proceed with the installation)