Momentum Cache installation problem --one solution

Bit Baby

Momentum Cache installation problem --one solution

One solution for one set of circumstances:


Momentum Cache would not fully install for me with my new MX300 SSD. I tried the recommended solution of uninstalling then reinstalling (meaning starting from scratch with Storage Executive, completely reinstalling it, including Momentum Cache), BUT Momentum Cache would not fully install.


After much perseverance (meaning repeating the reinstall process a few more times with one minor variation where I rebooted my PC after the uninstall but before the re-install) that met with repeated failure I gave up and sent in a Customer Support request (but not even Crucial's Customer Support report page within Storage Executive would work properly--it froze at the point where I agreed to allow Crucial Customer Support to proceed with automatically collecting 4 log files from my PC--very frustrating).


Next day (today) I happened to notice that my Windows 10 (version 1703 build 15063) Credentials Manager control panel would not open (some how its service file within the services folder was disabled??? ...I reenabled it and it returned to normal)...


Then I wondered if anything else in my system had been changed lately... by lately I mean during the beginning of my recently installing my Crucial SSD. The only thing I could think of was that when transferring my OS from my hard drive to the SSD (which went well) the two partions created by the software I used to do the transfer (MiniTool's Partition Magic-free edition) were automatically named System (G) and Windows (C).


NORMALLY the System partion does not have a letter assigned to it which thereby keeps this small partition hidden (meaning not being listed within any window file directory) ...So I went back into Partition Magic and changed the partition letter to "none"...then I reattempted to install Momentum Cache and it finally installed!


I don't understand how turning Credential Manager's service back on might have been part of the solution, but I can easily understand how Momentum Storage's installation software might have expected the system partition NOT to have a letter assigned to it and so got hung-up trying to find my PC's unlettered system partition when my system partition was in fact named: System X (where X stands for any letter).


I hope Crucial sees this message and incorporates it as a troubleshooting footnote within the future editions of their SSD installation instructions. I will try to email them a copy of this. Hopefully their Customer Support report page is working, but its the weekend so first I'm posting this here for possibly quicker access by anyone else dealing with this very frustrating problem.

2 Replies
Community Manager

Re: Momentum Cache installation problem --one solution

Hello Vector Victor,


Thanks for your message and I’m happy you managed to resolve the problem you had with Momentum Cache. Thanks also for sharing your experience and troubleshooting steps with the rest of the community. Our forum would be nothing without our helpful customers reaching out to share their hints and tips, so I have given you a Kudos to thank you.


Have a great day!

Crucial_NG, Crucial Moderator, UK

How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: Momentum Cache installation problem --one solution

Latest version of Storage Executive.

I'm afraid I've had the same problem, gone through the same procedures and had a similar experience with 'Help' (no reply at all, actually). Same MX300 SSD.

In my case Credentials Manager is running (manual). And I only have one Win10 drive, labelled C, plus a second physical HD for data labelled D. There is no other separate system drive, labelled or unlabelled. So I cannot apply the solution suggested in the previous post from VectorVictor..

I do have the latest firmware installed for the Crucial MX300 SSD. And the Momentum Cache app worked perfectly with the previous version of Storage Executive. So why does it now fail with the message 'Failure to download cache driver'?

This is by no means critical - but it is irritating...